RTX3070 Ti not used by rendering processes on Ubuntu 20.04 with driver 510.60


I have a new MSI laptop with RTX 3070 Ti. Installed Ubuntu 20.04 with nvidia driver 510.60. The nvdia-smi command can be run successfully. But seems not used by other processes other than xorg.

When running the glxgears, the GPU usage is still 0%. Attached the nvidia-bug-repor
nvidia-bug-report.log.gz (492.1 KB)

Any other mis-configurations? Thanks.

You’re in render offload mode
Use the variables or right-click on application starter->run on dgpu or whatever ubuntu uses.
If you want to run everything on the nvidia gpu, switch to performance mode in nvidia-settings or run sudo prime-select nvidia

Thanks for the quick reply.
I tried sudo prime-select nvidia (without rebooting), but seems nothing changes. I also tried to connect to an external monitor, but is was not detected by GPU either.

prime-select needs a reboot

Unfortunately, the laptop cannot boot properly after prime-select nvidia.
Tried the recovery mode to boot, also stuck at black screen.

Try booting to text console, in grub menu edit the kernel command line, add


then boot.

Thanks. I can tried to boot in the text console with root in recovery mode.
After booting to text mode, what would be the next steps?

Create a new bug-report.log, switch back to on-demand mode.

Sorry for the late update.

After I changed to “prime-select nvidia” and reboot, the built in monitor did not display. However, external monitor works with the nvidia driver rendering. Disconnect the external monitor, the built-in monitor still does not works.

Already tried this approach, Built-in laptop screen not detected when using Nvidia driver - Ask Ubuntu, still the same issue.

Regenerated the report.log.gz as attached. How to fix this so that nvidia driver can display both on built-in and external monitor? Thanks.

nvidia-bug-report.log.gz (294.2 KB)

The problem is your 12th gen intel gpu. The ubuntu 20.04 stock kernel is too old to drive it, please try upgrading kernel+firmware using the liquorix ppa and then manually installing updated firmware package

1 Like

Thanks! Finally everything works!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.