NVIDIA GeForce RTX 3060 Mobile graphics card detected but not working on Manjaro Linux

I honestly am just completely lost on what to do and this is a fresh install of Manjaro Linux with it completely updated, as you can see my NVIDIA GPU is detected but in my about this system it is not using this GPU and when I play a game it does not use my GPU. I even tried using the prime-run command to launch the game and it does not work but it does launch. I know in the NVIDIA settings to the right it is missing opengl page I think and I get no prime profiles. I know on Ubuntu / Ubuntu based systems like Zorin 16.1 everything works just fine but I really want to switch to arch based systems but this driver issue makes it to where I can not.
my PC is a ROG strix G17
Edit: I am using the proprietary drivers and the one I have installed is video -hybrid-amd-nvidia-prime
no matter if I have the default one or the other options for me switching them makes no difference at all. I have literately tried everything to my knowledge and tried to follow the other posts here to see if it would fix my problem but it has not.

I know this file is needed though:
nvidia-bug-report.log.gz (260.3 KB)

You’re in offload mode, use prime-run to start applications on the nvidia gpu, e.g.
prime-run glxgears

Thank you for responding,
I have done the glxgears with and without the prime-run and I still get the same frame-rate but I do not know if that matters or not.

how do I disable offload mode be default to get my GPU working for games? because I have put in the prime-run command in my steam game launch options and launched from the terminal bit even though my GPU should be used it is not using it. I know it is not using it because of massive lag, some games tell me what GPU I am using, and my fans are not really even going off like they should be.

For steam, use
in launch options.
glxgears is locked to vsync, you’ll always get your monitor’s refresh rate.
Test for correct gpu:
__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia glxinfo |grep vendor
should return Nvidia

To have the nvidia gpu run everything as primary gpu, you could install and use optimus-manager to switch.

Thank you I will try this with call of duty infinite warfare as I know that game tells my what GPU I am using in my settings. I will edit this post after it is done downloading and I test these methods ^_^

edit: so for some reason it just works with the game and no issues and I did not apply the settings so I will try other games like DOOM 2016 / Eternal and ARK and see if I just is working now and if not see if the commands you have gave me will just work witch makes absolutely no sense to me. I will make a new post with my discovery tomorrow as I need to get to bed.

So I do not know what else to say but my GPU is just working for all my games with nothing special set up or command to run it. I think what solved it was a bios update because last time I did this it was just one version older bios version and I think that is why it did not work then. I say it is weird because the new bios update just says “security update” and that is it with no other information on what it has fixed. Thank you for helping me and to those who have this issue run the command in your steam launch options like generix says:

make sure your bios is always updated people, even if you think it might not help because in my case it did.

games I tested:

  • ARK (with proton not native)
  • call of duty infinite warfare
  • Doom 2016 and Eternal

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.