Problem with nvidia-440xx-prime render offload - Linux Manjaro Notebook

Hello everybody! I’m here to find how to solve my technical issue that is happening with me since I reset my manjaro linux. Please, help me, because all i want is use my dedicated graphic card that is disabled at this moment and a long time ago.

I’ve tried to use optirun with bumblebeed to switch the gpu that would run the game, i’ve tried a lot o things bot nothing worked. In my last try, my whole screen was black when i restarted notebook.

Well, i’m using a notebook (acer aspire F5-573G-50KS with the graphic card Nvidia Geforce 940MX and a Intel HD Graphics) with Manjaro linux and in the System Configuration -> Hardware Configuration i clicked in “Auto install Proprietary Driver”, and manjaro installed successfully “video-hybrid-intel-nvidia-440xx-prime” to Geforce 940MX and “video-hybrid-intel-nvidia-440xx-prime” to Intel Graphics 620.

After that, i tried to run nvidia-settings, and this error happened:

ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system

So, i searched a lot and tried to run “prime-run nvidia-settings”, and the same error occurred.

I tried too the following commands:

  • "prime run nvidia smi" and “nvidia-smi”. Result:
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
  • "__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia glxinfo | grep vendor". Result:
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  152 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  39
  Current serial number in output stream:  40
  • "prime-run glxinfo". Result: The same as the last command

  • "glxinfo | grep “OpenGL renderer”. Result:

OpenGL renderer string: Mesa Intel(R) HD Graphics 620 (KBL GT2)

Please, do i have to install more things or libraries? Other config to do? It is because my video card doesn’t support nvidia-440x-prime driver?

I have these drivers installed too:

I tried to install nvidia driver by downloading it to the official site too, but problems to install, there was a header kerner error, looking for kernel.h file:

ERROR: The kernel header file '/lib/modules/5.4.31-1-MANJARO//include/linux/kernel.h' does not exist.  The most likely reason for this is that the kernel source path '/lib/modules/5.4.31-1-MANJARO/' is incorrect.

Maybe i should do something like this? : https://medium.com/@vfbsilva/howto-set-up-prime-with-nvidia-proprietary-driver-c647e3597447

Maybe manjaro installed wrong driver?

Pleease. Thanks so much!
Pedro Egg

nvidia-bug-report.log (268.9 KB)

I don’t know about manjaro/arch but as far as I can tell you did the correct steps by just hitting “auto-install proprietary drivers”. For unknown reasons, just the tools got installed but neither driver nor kernel headers.
!WARNING! don’t use the downloaded .run installer, authorized personnel only.
it exited early, so no harm done.
Please revert to manjaro forums, at least I can only tell yo that the package manager failed to install any driver.

1 Like

Hello! Thanks to support me! Okay, i will not use .run installer.

I made a post on manjaro forums, and they did a great job! Problem solved! Thanks again :)

Here’s the link, if someone has the same trouble: https://forum.manjaro.org/t/problem-with-nvidia-440xx-prime-render-offload-linux-manjaro-notebook/135398/5

Pedro Egg