You do not appear to have an NVIDIA GPU supported "Nvidia Geforce 940MX"

Hello,

I just downloaded the driver for Nvidia Geforce 940MX on Deepin Linux 15.5 - 64 bit. But when I ran the installer, It gave the following warning:

WARNING: You do not appear to have an NVIDIA GPU supported by the 387.34 NVIDIA Linux graphics driver installed in this system. For further details, please see the appendix SUPPORTED NVIDIA GRAPHICS CHIPS in the README available on the Linux driver download page at www.nvidia.com.

here is the nvidia-installer log:

nvidia-installer log file ‘/var/log/nvidia-installer.log’
creation time: Tue Dec 26 23:46:16 2017
installer version: 387.34

PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

nvidia-installer command line:
./nvidia-installer

Unable to load: nvidia-installer ncurses v6 user interface

Using: nvidia-installer ncurses user interface
-> Detected 4 CPUs online; setting concurrency level to 4.
WARNING: You do not appear to have an NVIDIA GPU supported by the 387.34 NVIDIA Linux graphics driver installed in this system. For further details, please see the appendix SUPPORTED NVIDIA GRAPHICS CHIPS in the README available on the Linux driver download page at www.nvidia.com.
-> The file ‘/tmp/.X0-lock’ exists and appears to contain the process ID ‘544’ of a runnning X server.

You should use 340.104 drivers.

Also always prefer your distro drivers over NVIDIA drivers because NVIDIA drivers are not safe to use if you don’t understand how to use them properly.

well,

if I use the distro driver, I’m not sure if it is using nvidia or not,

when I do:
lspci -k | grep -A 2 -i “VGA”

I get this:
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)
Subsystem: Acer Incorporated [ALI] HD Graphics 520
Kernel driver in use: i915

How do I make sure that it is using nvidia at least when gaming… When I try to open nvidia x server settings, it says:

You do not appear to be using the NVIDIA X Driver, Please edit your x configuration file (just run ‘nvidia-xconfig’ as root) and restart the X server.

When I run nvidia-xconfig

it says command not found.

Is the nvidia gpu enabled in bios?
Please post a full
sudo lspci
output.

Not sure about BIOS. I don’t know if there is an option about that or not.

output of sudo lspci:

00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #9 (rev f1)
00:1d.2 PCI bridge: Intel Corporation Device 9d1a (rev f1)
00:1d.3 PCI bridge: Intel Corporation Device 9d1b (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
01:00.0 3D controller: NVIDIA Corporation Device 179c (rev ff)
03:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader (rev 01)
04:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)

It’s an optimus system, you shouldn’t have used the .run installer but the driver from repositories, like birdie said. You should uninstall it, then reinstall mesa using

sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri
sudo dpkg-reconfigure xserver-xorg

after that install the drivers from the repositories and the package nvidia-prime
If the driver is then still complaining about no nvidia gpu found, try kernel parameter
pcie_port_pm=off

well, I didn’t go through with the installer as soon as I saw that warning. I’m using the drivers from driver manager but I think it is still using the Intel driver. Should I still follow all these commands? and how to do that kernel parameter thing?

ok. To have more info, please run nvidia-bug-report.sh as root and attach the tar.gz file it creates to your post.
Might be in /usr/lib/nvidia-XXX/bin with XXX being the major version of the nvidia driver.

So, I ran this but I didn’t find that file in there. Here was the output:

nvidia-bug-report.sh will now collect information about your
system and create the file ‘nvidia-bug-report.log.gz’ in the current
directory. It may take several seconds to run. In some
cases, it may hang trying to capture data generated dynamically
by the Linux kernel and/or the NVIDIA kernel module. While
the bug report log file will be incomplete if this happens, it
may still contain enough data to diagnose your problem.

Please include the ‘nvidia-bug-report.log.gz’ log file when reporting
your bug via the NVIDIA Linux forum (see devtalk.nvidia.com)
or by sending email to ‘linux-bugs@nvidia.com’.

Running nvidia-bug-report.sh…ls: cannot access ‘/proc/driver/nvidia/./gpus/’: No such file or directory

If the bug report script hangs after this point consider running with
–safe-mode command line argument.

complete.

the tar.gz file is in your current directory.

here you go:
https://pastebin.com/s6KmG9JP

bbswitch is shutting off the nvidia gpu so the binary driver didn’t detect it. You can forget about the kernel parameter.
Do you happen to have bumblebee installed? If so, uninstall it, it blacklists the nvidia driver.

I think I don’t have the other option available other than bumble bee. See this:

so what do you suggest now?

Either use bumblebee or see if the package nvidia-prime is available for your system.

when i try to do sudo apt-get install nvidia-prime, I get this:

Reading package lists… Done
Building dependency tree
Reading state information… Done
Package nvidia-prime is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘nvidia-prime’ has no installation candidate

it means not available?

Not available. It’s an Ubuntu package, I don’t know what package sources Deepin uses. So just use bumblebee, e.g.
primusrun nvidia-settings
or
optirun nvidia-settings
for maximum performance, you would have to set up prime by hand:
https://devtalk.nvidia.com/default/topic/1022670/linux/official-driver-384-59-with-geforce-1050m-doesn-t-work-on-opensuse-tumbleweed-kde/post/5203910/#5203910

okay, I’ll try that. Thanks!