[ASUS-K46CB GF740m] Xorg: Failed to initialize the NVIDIA graphics device!

Hello! After installation of Ubuntu 13.04 on my new laptop I got error message “The system is running in low-graphics mode”. After some attemps to start x-server and install drivers, I tried to install nvidia-325 proprietary drivers and bumblebee. But it still prints this error message. Deinstallation of bumblebee and reinstallation of drivers was not helpful.
I also unsuccessfully tried nvidia-current, nvidia-304, nvidia-325,310 from two different repos, 319 official from Nvidia Web-site, and even 3.9-rc8, 3.10.10, 3.11 kernels.
After a few days of torment the system was surprisely started without error mesage, but Nvidia card still not works.

This is my Xorg.8.conf output
http://pastebin.com/6YyZGs5Z

This is my dmesg output
http://pastebin.com/KLW87Q2i

$ optirun firefox
[ 6314.025057] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please

[ 6314.025164] [ERROR]Aborting because fallback start is disabled.
$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
$ lspci | grep 3D
01:00.0 3D controller: NVIDIA Corporation GK107M [GeForce GT 740M] (rev ff)
$ dkms status
bbswitch, 0.7, 3.8.0-19-generic, x86_64: installed
bbswitch, 0.7, 3.8.0-31-generic, x86_64: installed
i915-3.9-3.8, 0.02, 3.8.0-19-generic, x86_64: installed (WARNING! Diff between built and installed module!)
i915-3.9-3.8, 0.02, 3.8.0-31-generic, x86_64: installed
nvidia-304, 304.88, 3.8.0-19-generic, x86_64: installed
nvidia-304, 304.88, 3.8.0-31-generic, x86_64: installed
vboxhost, 4.2.16, 3.8.0-19-generic, x86_64: installed
vboxhost, 4.2.16, 3.8.0-31-generic, x86_64: installed
$ cat /proc/acpi/bbswitch 
0000:01:00.0 OFF

nouveau blacklisted in modeprobe.d

/var/log/kern.log
http://soudesune.ru/uploads/kern.txt

Your GPU is powered off when the driver is attempting to load, which is why it’s failing. You’ll need to figure out what power-saving feature is powering off the GPU and disable it.

Thank you for answering.
It is only bbswitch that powering off my Nvidia GPU. But it needs for bumblebee’s working…
I don’t now what to do.

I found that v.304 drivers don’t work with my GPU. Then I removed 304 and installed 325 from repository.
This is an output:

<b>$ optirun firefox</b>
[ 2692.826537] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 2692.826601] [ERROR]Aborting because fallback start is disabled.
<b>$ sudo modprobe nvidia_325</b>
ERROR: could not insert 'nvidia_325': Invalid argument

dmesg:

[ 2689.203578] bbswitch: enabling discrete graphics
[ 2689.336165] pci 0000:01:00.0: power state changed by ACPI to D0
[ 2689.356623] nvidia: disagrees about version of symbol drm_pci_init
[ 2689.356626] nvidia: Unknown symbol drm_pci_init (err -22)
[ 2689.356671] nvidia: disagrees about version of symbol drm_gem_prime_handle_to_fd
[ 2689.356672] nvidia: Unknown symbol drm_gem_prime_handle_to_fd (err -22)
[ 2689.356691] nvidia: disagrees about version of symbol drm_gem_private_object_init
[ 2689.356692] nvidia: Unknown symbol drm_gem_private_object_init (err -22)
[ 2689.356757] nvidia: disagrees about version of symbol drm_gem_handle_create
[ 2689.356758] nvidia: Unknown symbol drm_gem_handle_create (err -22)
[ 2689.356803] nvidia: disagrees about version of symbol drm_pci_exit
[ 2689.356804] nvidia: Unknown symbol drm_pci_exit (err -22)
[ 2689.356827] nvidia: disagrees about version of symbol drm_gem_prime_export
[ 2689.356828] nvidia: Unknown symbol drm_gem_prime_export (err -22)

Kernel 3.8.0-19

That last error sounds like the kernel module was compiled against a different version of the kernel than the one you’re trying to load it into. Are you sure your distribution’s packages are installed correctly?

Oh God, i installed 3.8.9 kernel and it works! Amazing! I tried several times with different kernels and drivers.
:)