RTX4090 530.* Drivers not working on wayland/Gnome - Screen turns off - "Works" on Xorg


So, i’m running a RTX4090 connected to na Apple Studio Display (5K).

After a clean install on:


As soon as the latest nvidia drivers (530.*) are installed, screen turns off as soon as the display manager (GDM being the default) starts…

KDE/plasma with SDDM display manager works just fine.

to get my computer to a working state, namely gnome, to work, i’ve had to:

  • export my screen EDID from nvidia settings panel, along a functional xorg.conf file, and loaded them thru /etc/X11/xorg.conf.d/99-xxxx.conf
  • install a third party display manager, lightdm, and upon load, select “gnome on xorg”, this way, everything loads.

Here’s the output of journalctl -b with gdm set as display manager

The only instance I managed to launch gnome on wayland is if I install ubuntu LTS 22.04, Nvidia Drivers 525.* and even then, for some reason it’ll only work if I create a dummy 99-xxxx.conf file again with:

Section "Device"
      Driver "nvidia"

On the hardware side of things, I’m running an asus Z690-Creator motherboard, with thunderbolt video output (which my monitor demands), RTX is connected to motherboard’s DP in port.

Is there a known issue with current drivers + wayland (+existing kernel?) and GDM?

New users can only post 1 link a post, here’s another log:


The 525 and 530 drivers have a buG for newer GPU’s that causes Plasma Wayland at least to crash the system upon relogging in if your monitor is SET above 60hz. It MAY only affect multi monitor setups I dunno.

You can verify this by generating a new user account, and it should default that to 60hz, you can switch up higher hz in that session only, next time you try and log in with said account it will black-screen-lock-system…

NV has not really said much about it, or if they intend to fix it. Pretty big bug really.

I’m experiencing the same issue.

The last driver that worked for we was: 525.89.02

Every driver since has had this issue.

I have no choice but to use the HDMI output of the 3080 because my monitor only accepts HDMI in. I hope it gets fixed soon. It’s unacceptable, really.

NVIDIA-SMI 530.41.03
Driver Version: 530.41.03
CUDA Version: 12.1

I have the same issue as poster. Ubuntu 22.04 Desktop with 545 Nvidia drivers (and CUDA).

Blank screen when GDM starts but only with the Apple Studio Display connected to my RTX 4090’s DisplayPort. When I try the same configuration with an old LG 1080p display connected to HDMI port I get the login prompt and Gnome seems to run fine.

I tried lightDM and made it to the graphical login prompt with the Studio Display but got a black screen once I’ve entered my credentials.