Run Deepstream 6.2 on Ubuntu 22.04

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) - DGPU
• DeepStream Version - 6.2
• TensorRT Version - 8.5.2
• NVIDIA GPU Driver Version (valid for GPU only) - Driver 535

I am trying to run Deepstream 6.2 on a ubuntu 22.04 docker image, but getting issues in compilation due to glibc and g++ / gcc versions. Is Deepstream 6.2 supported on ubuntu 22.04. My dependencies didn’t have any errors. I was able to install cuda 12.2 for the latest driver and cuda 11.8 for deepstream 6.2 and TRT as well.

The reason I wanted to run it on ubuntu 22.04 image instead of nvidia’s docker image is because ubuntu 22.04 image has much lesser number of vulnerabilities.

DeepStream can run on native Ubuntu20.04, please refer to the dependencies below:

  • Ubuntu 20.04
  • GStreamer 1.16.3
  • NVIDIA driver 525.85.12
  • CUDA 11.8
  • TensorRT 8.5.2.2

Thanks, but can it run on Ubuntu 22.04 LTS as well?

We didn’t verify this case.
There are some topics in the forum about using Deepstream6.2 in Ubuntu22.04, different dependencies/installations are met, and I didn’t see a guide on how to run DS62 on Ubuntu22.04 so far.

Thanks, can you send me the link for these forums

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

You can search it in this forum, here is an example: Search results for ‘22.04 #intelligent-video-analytics:deepstream-sdk’ - NVIDIA Developer Forums