Deepstream Instaltion

Hi,

I am trying to install Deepstream 6.4 by following the steps from the documentation inside Docker. The base image is ubuntu22:04, but I am getting the error below.

We have DeepStream docker already, why not simply use it, or use it as your base image? DeepStream | NVIDIA NGC

Please provide complete information as applicable to your setup.
• Hardware Platform (Jetson / GPU)
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)
• The pipeline being used

Deepstream 6.4
Ubuntu 22.04
Docker version 25.0.0

To reproduce it you can try to build this Dockerfile:

# syntax=docker/dockerfile:1

FROM ubuntu:22.04

RUN apt update && apt upgrade -y && apt install -y curl && \
    apt install -y sudo wget rsync && \
    apt install -y libssl3 libssl-dev libgstreamer1.0-0 gstreamer1.0-tools && \
    apt install -y gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly gstreamer1.0-libav && \
    apt install -y libgstreamer-plugins-base1.0-dev libgstrtspserver-1.0-0 libjansson4 libyaml-cpp-dev libjsoncpp-dev protobuf-compiler gcc gdb make git python3 cmake

RUN apt install -y gnupg software-properties-common && \
    apt-key adv --fetch-keys https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2204/x86_64/3bf863cc.pub && \
    add-apt-repository "deb https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2204/x86_64/ /" && \
    apt-get update &&  apt install -y cuda-toolkit-12-2

RUN  apt-get install libnvinfer8=8.6.1.6-1+cuda12.0 libnvinfer-plugin8=8.6.1.6-1+cuda12.0 libnvparsers8=8.6.1.6-1+cuda12.0 \
    libnvonnxparsers8=8.6.1.6-1+cuda12.0 libnvinfer-bin=8.6.1.6-1+cuda12.0 libnvinfer-dev=8.6.1.6-1+cuda12.0 \
    libnvinfer-plugin-dev=8.6.1.6-1+cuda12.0 libnvparsers-dev=8.6.1.6-1+cuda12.0 libnvonnxparsers-dev=8.6.1.6-1+cuda12.0 \
    libnvinfer-samples=8.6.1.6-1+cuda12.0 libcudnn8=8.9.4.25-1+cuda12.2 libcudnn8-dev=8.9.4.25-1+cuda12.2 && \
    # install Deepstream
    wget 'https://api.ngc.nvidia.com/v2/resources/nvidia/deepstream/versions/6.4/files/deepstream-6.4_6.4.0-1_amd64.deb' && \
    apt install -y ./deepstream-6.4_6.4.0-1_amd64.deb && \
    /opt/nvidia/deepstream/deepstream/update_rtpmanager.sh &&  \
    bash -c 'echo "/opt/nvidia/deepstream/deepstream/lib" > /etc/ld.so.conf.d/deepstream.conf' && \
    ldconfig

This was not an issue, I have managed to build it before.

please refer to this topic for issue “libnvinfer-headers-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed”.

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks