Fails to install DeepStream in docker container

Hi all,

This is my setup.
• Hardware Platform GPU ubuntu22.04 x86
• DeepStream Version 6.3 and 6.4

I was previous installing DeepStream 6.3 on a docker container which has a FROM nvidia/cuda:12.2.2-devel-ubuntu22.04.

I was able to install it until last week, when I had to update my docker image, the DeepStream installation failed with the following error:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libnvparsers-dev : Depends: libnvinfer-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed```

Any suggestion to solve that? I have the same problem when trying to install 6.4 version.

Thanks in advance,

Hello,

I have the same problem in this side. Any suggestion to solve this problem?

For now, the temporary solution that I found is to update the nvidia cuda repository gpg key to ubuntu18.04, even though I am running ubuntu22.04.

I don’t like this solution at all, but it was the best I could find.

Here are two suggestions

  1. Use the docker image provided by deepstream
  1. If you want to build the image yourself, please refer to this project.

@junshengy thanks for the reply, I already looked at this repo before deepstream_dockers/x86_64/ubuntu_base_devel/Dockerfile at main · NVIDIA-AI-IOT/deepstream_dockers · GitHub.

I noticed that the docker file for ubuntu_base_devel is empty.

Can you provide me a Dockerfile for ubuntu2204 base devel or can I go with the runtime and adapt it?

In fact DS-6.4 is based on ubuntu22.04, you can refer to this