DeepStream 6.4 installation fails

Please provide complete information as applicable to your setup.

**• Hardware Platform ** dGPU RTX 3070Ti on Laptop
• DeepStream Version 6.4
• TensorRT Version 8.6.1.6
• NVIDIA GPU Driver Version (valid for GPU only) 535.171.04 Nvidia, Tested
**• Issue Type( questions, new requirements, bugs) Bug

DeepStream 6.4 installation fails (followed the Quickstart guide for DeepStream)
root@ufuk-Legion-5-Pro-16IAH7H:/home/ufuk/Downloads# apt-get install ./deepstream-6.4_6.4.0-1_amd64.deb
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Note, selecting ‘deepstream-6.4’ instead of ‘./deepstream-6.4_6.4.0-1_amd64.deb’
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libnvparsers-dev : Depends: libnvinfer-dev (= 8.6.1.6-1+cuda12.0) but 10.0.1.6-1+cuda12.4 is to be installed
E: Unable to correct problems, you have held broken packages.

**• How to reproduce the issue ? Follow the quickstart guide on Quickstart Guide — DeepStream documentation 6.4 documentation

Manually installing the unmet dependencies does not solve the issue mentioned here:

Try the methods mentioned in this topic, some people have solved the problem through these methods.

Or I strongly recommend you to use docker,This will avoid a tedious installation.

docker run --gpus all -it --rm --net=host --privileged -v /tmp/.X11-unix:/tmp/.X11-unix -e DISPLAY=$DISPLAY -w /opt/nvidia/deepstream/deepstream-6.4 nvcr.io/nvidia/deepstream:6.4-gc-triton-devel

Thanks for the information, can I use this docker for the RTX 3070Ti Notebook GPU? Is that considered as enterprise GPU?

RTX 3070Ti Notebook GPU is not enterprise GPU.

But I think it should be able to run normally on the docker. I tried it on 3060