Can't install Deepstream 5.1 on RTX2070 dGPU

Hello guys!

I’m trying to install Deepstream-5.1 on RTX2070. I got this error:

sudo apt-get install ./Downloads/deepstream-5.1_5.1.0-1_amd64.deb
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘deepstream-5.1’ instead of ‘./Downloads/deepstream-5.1_5.1.0-1_amd64.deb’
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
deepstream-5.1 : Depends: cuda-cudart-11-1 but it is not installable
Depends: cuda-cudart-dev-11-1 but it is not installable
Depends: libnpp-11-1 but it is not installable
Depends: libnpp-dev-11-1 but it is not installable
Depends: libnvinfer7 (>= 7.2.1) but it is not going to be installed
Depends: libnvinfer-dev (>= 7.2.1) but it is not going to be installed
Depends: libnvparsers7 (>= 7.2.1) but it is not going to be installed
Depends: libnvparsers-dev (>= 7.2.1) but it is not going to be installed
Depends: libnvonnxparsers7 (>= 7.2.1) but it is not going to be installed
Depends: libnvonnxparsers-dev (>= 7.2.1) but it is not going to be installed
Depends: libnvinfer-plugin7 (>= 7.2.1) but it is not going to be installed
Depends: libnvinfer-plugin-dev (>= 7.2.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Anyone can help me to solve this, please?

Please install these dependency first then install deepstream.

CUDA: 11.1
cuDNN: 8.0.0+
TensorRT: 7.2.2
Driver: R460.32+

Thanks Amycao!

The issue was that NVIDIA Docs has some misunderstanding in their documentation, it shows 11.2Version and 11.1V is required for Deepstream 5.1.

What I did was downgrade the 11.2V to 11.1V (Cuda) and it works perfectly!

Thanks!

JJ

Can you tell how you downgraded? using the Cuda 11.1 runfile? It does problems for me

I succeeded with:
“sudo sh cuda_11.1.0_455.23.05_linux.run --toolkit”. I wish this was written in NVIDIA’s DS5.1 installation instructions. The link there is wrong and leads to toolkit 11.2.

Sure thing!

sudo apt-get remove nvidia-cuda-toolkit
sudo apt-get purge nvidia-cuda-toolkit
sudo apt-get purge --auto-remove nvidia-cuda-toolkit

After that, you can install Cuda11.1V in this link

Then, you could install Deepstream5.1 normally

Cheers,
JJ

1 Like

Thanks a lot!

By the way, this will guarantee that cuda toolkit will not be upgraded to 11.2 when Ubuntu automatic updates take place?

You need do download the cuda package and install it manually.

1 Like

Hello,
I am facing the same issue, I have ubuntu 20.04 but seems like Deepstream requires 18.04 as per the website, do I need to downgrade it to 18.04?

You can use docker for ease use.

https://docs.nvidia.com/metropolis/deepstream/dev-guide/text/DS_docker_containers.html#a-docker-container-for-dgpu

1 Like