Not able to install deepstream using debian package

From the documentation link, Quickstart Guide — DeepStream 6.2 Release documentation, I’m trying to install deepstream via debian package and I get below error.

nvidia@Chandra:~/Downloads$ sudo apt-get install ./deepstream-6.2_6.2.0-1_arm64.deb 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'deepstream-6.2' instead of './deepstream-6.2_6.2.0-1_arm64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 deepstream-6.2 : Depends: cuda-cudart-11-4 but it is not installable or
                           cuda-cudart-11-7 but it is not installable
                  Depends: cuda-cudart-dev-11-4 but it is not installable or
                           cuda-cudart-dev-11-7 but it is not installable
                  Depends: libnpp-11-4 but it is not installable or
                           libnpp-11-7 but it is not installable
                  Depends: libnpp-dev-11-4 but it is not installable or
                           libnpp-dev-11-7 but it is not installable
                  Depends: libcufft-11-4 but it is not installable or
                           libcufft-11-7 but it is not installable
                  Depends: libgstreamer1.0-0 (>= 1.16.0) but 1.14.5-0ubuntu1~18.04.2 is to be installed
                  Depends: libgstreamer1.0-dev (>= 1.16.0) but 1.14.5-0ubuntu1~18.04.2 is to be installed
                  Depends: libgstreamer-plugins-base1.0-0 (>= 1.16.0) but 1.14.5-0ubuntu1~18.04.3 is to be installed
                  Depends: libgstreamer-plugins-base1.0-dev (>= 1.16.0) but 1.14.5-0ubuntu1~18.04.3 is to be installed
                  Depends: libnvvpi2 (>= 2.0.2) but it is not installable
                  Depends: libyaml-cpp-dev (>= 0.6.2) but 0.5.2-4ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.

Details of my system configuration are below:
CUDA: 10.2.300
cuDNN:8.2.1.32
TensorRT:8.2.1.8
Jetson: Nano
Ubuntu: 18.04
OpenCV: 4.1.1.
Jetpack:4.6.1

Could you pls help to resolve this? Thank you.

Jetson nano can only support up to version 6.0.1.

please refer this document for more information

Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.