Cannot install deepstream 6.4

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) Quadro 5000
• DeepStream Version 6.4
• TensorRT Version 8.6
• NVIDIA GPU Driver Version (valid for GPU only) 535.104.05
• Issue Type( questions, new requirements, bugs)
**• How to reproduce the issue ? sudo apt-get install /deepstream-6.4_6.4.0-1_amd64.deb

• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

I cannot install deep stream from the package

sudo apt-get install /deepstream-6.4_6.4.0-1_amd64.deb
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Note, selecting ‘deepstream-6.4’ instead of ‘/deepstream-6.4_6.4.0-1_amd64.deb’
The following NEW packages will be installed:
deepstream-6.4
0 upgraded, 1 newly installed, 0 to remove and 4 not upgraded.
4 not fully installed or removed.
Need to get 0 B/788 MB of archives.
After this operation, 1 036 MB of additional disk space will be used.
Get:1 /deepstream-6.4_6.4.0-1_amd64.deb deepstream-6.4 amd64 6.4.0-1 [788 MB]
(Reading database … 230927 files and directories currently installed.)
Preparing to unpack …/deepstream-6.4_6.4.0-1_amd64.deb …
Unpacking deepstream-6.4 (6.4.0-1) …
dpkg: error processing archive /deepstream-6.4_6.4.0-1_amd64.deb (–unpack):
trying to overwrite ‘/opt/riva/backends/libtriton_riva_asr_decoder_cpu.so’, which is also in package deepstream-6.2 6.2.0-1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
/deepstream-6.4_6.4.0-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Have you remove-all-previous-deepstream first?

Yes with uninstall.sh and /opt/nvidia/deepstream is empty

OK. There may be a conflict with DeepStream 6.2 from the log attached. Did you install deepstream 6.2 in the following way?

sudo apt-get install /deepstream-<version>.deb

Since DeepStream 6.4 may also be accompanied by some other software upgrades, could you describe in detail all the upgrades from 6.2 to 6.4?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.