Unable to install Deepstream 6.4 on dGPU

I am trying to install Deepstream on my Dell XPS15 laptop with 4060 GPU / 32GB RAM / Core i9, running Ubuntu 22.04 and nvidia drivers 535

I followed the steps at Quickstart Guide — DeepStream documentation 6.4 documentation

However, when I run:
sudo apt-get install libnvinfer8=8.6.1.6-1+cuda12.0 libnvinfer-plugin8=8.6.1.6-1+cuda12.0 libnvparsers8=8.6.1.6-1+cuda12.0 libnvonnxparsers8=8.6.1.6-1+cuda12.0 libnvinfer-bin=8.6.1.6-1+cuda12.0 libnvinfer-dev=8.6.1.6-1+cuda12.0 libnvinfer-plugin-dev=8.6.1.6-1+cuda12.0 libnvparsers-dev=8.6.1.6-1+cuda12.0 libnvonnxparsers-dev=8.6.1.6-1+cuda12.0 libnvinfer-samples=8.6.1.6-1+cuda12.0 libcudnn8=8.9.4.25-1+cuda12.2 libcudnn8-dev=8.9.4.25-1+cuda12.2
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
libnvinfer-dev : Depends: libnvinfer-headers-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed
libnvinfer-plugin-dev : Depends: libnvinfer-headers-plugin-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed
libnvinfer-samples : Depends: libnvinfer-lean-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed or
libnvinfer-lean-dev-cross-amd64 (= 8.6.1.6-1+cuda12.0) but it is not installable
Depends: libnvinfer-dispatch-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed or
libnvinfer-dispatch-dev-cross-amd64 (= 8.6.1.6-1+cuda12.0) but it is not installable
Depends: libnvinfer-vc-plugin-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed or
libnvinfer-vc-plugin-dev-cross-amd64 (= 8.6.1.6-1+cuda12.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

Similarly, when I try to install the deepstream deb package, I run into the following error:
sudo apt install ~/Downloads/deepstream-6.4_6.4.0-1_amd64.deb
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Note, selecting ‘deepstream-6.4’ instead of ‘/home/inder/Downloads/deepstream-6.4_6.4.0-1_amd64.deb’
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
libnvparsers-dev : Depends: libnvinfer-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed
E: Unable to correct problems, you have held broken packages.

How do I fix this? Thanks

I was able to fix this problem by downloading the right libraries from Index of /compute/cuda/repos/ubuntu2204/x86_64 and install them manually before installing deepstream.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.