Run nvgstiva-app without X11?

Trying to play with nvgstiva-app using default config file PGIE-FP16-CarType-CarMake-CarColor.txt.
While it works when X11 server is running, it fails with the following error without X11 server:

------------> -----------------
** ERROR: <create_secondary_gie:105>: Failed to create ‘secondary_gie_0’
** ERROR: <create_secondary_gie:235>: create_secondary_gie failed
** ERROR: <create_secondary_gie_bin:364>: create_secondary_gie_bin failed
** ERROR: <create_processing_instance:891>: create_processing_instance failed
** ERROR: <create_pipeline:1025>: create_pipeline failed
** ERROR: main:384: Failed to create pipeline
App run failed

Any idea why? Config file has sink type=2 which is nvoverlaysink and nvoverlaysink doesn’t need X11…


Type 2 mean overlaysink, it access our hw DC directly.
While 3 eglsink use EGLImage+OpenGLes, it is based on X11, you must enable it if you want to support eglsink.

wayne zhu

Yeah, that’s what I thought. Anyways, somehow I managed to “fix” it, so it works without X11 on our system now.


albertr - what did you do to make it work?

Good question, frankly I don’t remember. I think it had nothing to do with DeepStream or nvgstiva-app… We have multiple gstreamer installations and I was messing around switching from one of them over to another. Might have been some environment variables which were affecting it, but I’m not sure…

Are you getting the same error?


just starting to play with it and was hoping to avoid beating my head on a rock.

I got the same error on a fresh installed Jetpack 3.2 and Jetpack 3.3.

Please help!

JetPack3.3 has no deepstream support till now.

Could you elaborate your issue you meet?

wayne zhu

Thanks, Wayne.

We got the " Failed to create ‘secondary_gie_0’" error on a freshly installed TX-2. After trying out for a while, “clearing the cache” fixed the issue.