Running gstreamer on a docker container (using a Jetson AGX Xavier device) : *gst-inspect-1.0 error*

Platform used: AGX Xavier
Jetpack: 5.0.2
L4T: R35 (release), REVISION: 1.0, GCID: 31346300, BOARD: t186ref, EABI: aarch64, DATE: Thu Aug 25 18:41:45 UTC 2022
Base container I’m using : (ldd --versionldd (Ubuntu GLIBC 2.27-3ubuntu1.4) 2.27 )


When I run gst-inspect-1.0 I get

gst-inspect-1.0: /lib/aarch64-linux-gnu/ version `GLIBC_2.29' not found (required by /usr/lib/aarch64-linux-gnu/

However when I run the command outside docker everything works fine (ldd --version outputs ldd (Ubuntu GLIBC 2.31-0ubuntu9.9) 2.31 ). I think the default runtime (nvidia) is set correctly.

    "data-root": "/mnt/ssd2/docker/data",
    "runtimes": {
        "nvidia": {
            "path": "nvidia-container-runtime",
            "runtimeArgs": []

I’ve added the l4t.csv file below.

can you please help. (my goal is to get nvidia accelerated gstreamer plugins working inside this container, Ideally I’d like to use more basic container but this is the one I used before so I stuck to it, suggestions are welcome on that too)

EDIT: can I update glibc here or is there a better suited container? (we plan to scale this up so I think it’d be better if we have an updated container)


P.S. Let me know if the question is unclear, I can try to explain more

This question looks a bit similar. but it looks like it hasn’t been definitively resolved. I’m planning to use pyds down the line but I think this glibc 2.29 visibility needs to be resolved first before doing pyds.

l4t.csv (15.5 KB)

Use or it’s derivatives

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.