Running Yolo on Live Webcam error

Hello all,

I have tried various ways to run yolov3 on Jetson Nano.
From the documentation it says the OpenCV compiled with GStreamer support…
So I was supposed I do not need to install opencv again and set the Gstreamer ON(I know that only opencv with python2 working).
With this explanation, Why I can not open the camera and it raises error?

Suppose I have to recompile Opencv in order to be able to run Yolov3 successfully. I followed this step https://github.com/AastaNV/JEP/blob/master/script/install_opencv4.0.0_Nano.sh to do so but still not getting the result and it can not open the camera.

Wouldnt be good someone which has tried on Jetson Nano share his/her steps?

Also, tried this one https://jkjung-avt.github.io/opencv3-on-tx2/ which is based on TX2, but it has major problem of shared libopencv…

Can someone who has successfully opened the camera using the opencv on Jetson Nano help please.

Thanks

Hi,

Would you mind to share the document link so we can checking it further?

The default OpenCV package doesn’t build with GStreamer support.
You will need to compile it with the script you shared.

After installing, you may have two openCV package.
So please check if you are using the OpenCV 4.0 rather than v3.3.

Thanks.

Sorry It was not in the documentation but a comment by NVIDIA Moderator.I need to find it then I will share here.

Do I need to explicitly install dev0? like this:

sudo apt-get install -y libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev

Thanks,

So, I am updating here, in case it will help somebody or we figure out the reason.
I could get Yolov3 run on Jetson Nano, using openCV 3.4, and usb camera.

With the same configuration when I used the onboard camera and of course changing the script to get it run with onboard camera it raises error

(it could not open the webcam!....)

(for the record I have followed this Github project for both USB and onboard camera).
That would be great if someone can help figure out the onboard camera.

Previously, I had done the same with openCV4, but I could not get Yolov3 run with Opencv4. However, I did not try with the USB camera, It might have worked if I had checked it with USB camera.

Further, I did not delete the already available opencv3.2 in the jetpack.
For installing opencv 3.4 I followed this guy approach: https://jkjung-avt.github.io/opencv3-on-tx2/, however, I skept deleting the available opencv.
Also, I changed the CMAKE file to get FFmpeg On, and some other things.
Do you think it might be the reason I could not run Yolo using the onboard camera?
I can share my cmake part if you think it might help to find the reason.

Thanks