RuntimeError: CHECK failed: (index) < (current_size_):

Linux version : Ubuntu 16.04 LTS
GPU type : GeForce GTX 1080
nvidia driver version : 410.93
CUDA version : 10.0
CUDNN version : 7.4.1
Python version [Anaconda] : 3.6.8
Tensorflow version : tensorflow-gpu 1.13.1
TensorRT version :

[libprotobuf FATAL /home/erisuser/p4sw/sw/gpgpu/MachineLearning/DIT/externals/protobuf/x86_64/10.0/include/google/protobuf/repeated_field.h:1408] CHECK failed: (index) < (current_size_): 
Traceback (most recent call last):
  File "", line 245, in <module>
  File "", line 219, in main
  File "/home/zcy/1_data_sets/TensorRT-", line 115, in __init__
  File "/home/zcy/1_data_sets/TensorRT-", line 75, in build_engine
    parser.parse(uff_model_path, network)
RuntimeError: CHECK failed: (index) < (current_size_):

I am using the uff_ssd example in tensorrt5.1.2.2.
I trained my model with ‘ssd_inception_v2_coco.config’ in tensorflow-api. When I used the script in uff_ssd, the model was converted from ‘.pb’ to ‘.uff’ and also generated '.pbtxt 'File.
But when building an engine, there is always the same error. The error message is as above.
When I use the default model ‘ssd_inception_v2_coco_2017_11_17’ in the uff_ssd script ‘’, everything works fine.
Any help will be appreciated!!!

Met the same error. Haven’t been able to solve it.

The NVIDIA sample model was generated in 2017 I suppose… while you’re training with tf object-detection-api, which is up to date. If you look at the graph in Tensorboard you’ll notice the difference in graph structures.

I met the same problem,have you resolved it?

Same issue here!

I met the same problem,have you resolved it?