SATA SSD/HDD Connection On TX1

Hey Gang,

So I’ve simply tried to connect a SSD (Samsung EVO 850) and I’m getting no information or detection from the Jetson.

I’ve been checking out cat /proc/mounts, df -aTH lsblk to aid my poor human eyes, and even apt-got gparted. None of these options have shown an sda device. All I am seeing is the mmcblk0p’s of what I can only assume is the on board flash storage.

Has anyone figured out how to mount an external drive on the TX1 or is that a kernel module/driver that is only coming later?

Thanks!

You won’t see anything on mounts or df until the SSD has a partition mounted. What is the output of “lsblk”? This lists block devices…you are correct that the mmcblk0pX entries are internal eMMC.

Expedient replies, great!

Output of lsblk:

NAME         MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
mmcblk0rpmb  179:16   0     4M  0 disk 
mmcblk0      179:0    0  14.7G  0 disk 
├─mmcblk0p1  179:1    0    14G  0 part /
├─mmcblk0p2  179:2    0     2M  0 part 
├─mmcblk0p3  179:3    0     4M  0 part 
├─mmcblk0p4  179:4    0     2M  0 part 
├─mmcblk0p5  179:5    0     6M  0 part 
├─mmcblk0p6  179:6    0     4M  0 part 
├─mmcblk0p7  179:7    0     6M  0 part 
├─mmcblk0p8  179:8    0     2M  0 part 
├─mmcblk0p9  179:9    0     2M  0 part 
├─mmcblk0p10 179:10   0    20M  0 part 
├─mmcblk0p11 179:11   0    64M  0 part 
├─mmcblk0p12 179:12   0    64M  0 part 
├─mmcblk0p13 179:13   0     4M  0 part 
├─mmcblk0p14 179:14   0     2M  0 part 
├─mmcblk0p15 179:15   0     6M  0 part 
├─mmcblk0p16 259:0    0     6M  0 part 
├─mmcblk0p17 259:1    0     2M  0 part 
└─mmcblk0p18 259:2    0   496M  0 part

Interesting…only eMMC shows. Was the SSD connected when you ran that lsblk? Also, have you tried a non-SSD hard drive on that (just to debug the cable)?

Yep SSD is connected and was connected during lsblk. Tried reseting the connection to no avail. Just tried plugging in another SSD and then another HDD and neither show up in lsblk.

Interesting, just did a fresh reboot with HDD plugged in, and now it’s showing up in lsblk. Alright, sorry for the false alarm and thanks for the assistance!

If it does turn out that the SSD shows up sometimes and not others, I’m sure posting that information with the SSD model would be of interest.

The simple answer here is that the TX1’s SATA port is not hot-swappable. I believe the manual says this, although it may not have been very clear about it.

It also does not reliably detect the SATA when only doing a reboot from the command line. I found that it needed a power cycle with the power switch to detect the drive reliably.

Hello, RACKGNOME:
SATA is verified Jetson TX1. You can attach the SATA HDD in board. After kernel up, /dev/sdax will appear. And you can mount.

br
ChenJian

Hi, I am using R24.1.
And I can’t see SATA HDD.

Could you please tell what I should go for configuration ?

Regards,

Tonie

Hello, Tonie:
SATA is enabled by default in kernel configuration. Just attach the SATA HDD with Jetson TX1 board and device node will appear.
if that fails, please check the kernel log and see whether there’s any error.

br
ChenJian

who designed this board, one capacitance is placed beyond the sata port, make it impossible to add a normal HDD or SSD on this board.

A cable such as this one was intended to work with the SATA port…direct hard drive attachment like a backplane was not intended:
http://www.newegg.com/Product/Product.aspx?Item=N82E16812400019&cm_mmc=CNETFinders--TVFinder--na-_-na

My experiences completely align with @TullyFoote:

Sometimes the mounted ssd just disappears for no reason (multiple ssd devices were tested, model TX1 R28) and rebooting from command line does not help, but usually manual power-on/off solves the problem…

could not find solution yet, kernel log file can be found here:
https://pastebin.com/UL7Zb9Wn

Thanks in advance

The logs don’t show anything related to the SATA port going away, though I did see evidence of where something went wrong from the prior boot not shutting down correctly:

Apr 03 02:09:10 tegra-ubuntu kernel: EXT4-fs (mmcblk0p1): warning: mounting fs with errors, running e2fsck is recommended

Where is the partition mounted? Is there any sort of load which triggers this? Would you be able to run “dmesg --follow” prior to doing something which would trigger the failure, and then save a log of what shows up as the error occurs? Note that serial console would be ideal for this since it’ll remain visible and logged even when the Jetson is powered down or failing…ssh might work as long as the error doesn’t kill networking (the host PC would have a copy of dmesg text).

You might also give more information on the specific device, and run “sudo gdisk -l” on that device to show how it is partitioned. Also list where it is mounted.