SDK install error: cannot find -lcuda make error: /usr/bin/ld: cannot find -lcuda

I’m running Fedora 14 on a 64-bit machine. I installed the drivers by running and the tookit by running Those seemed to work without any problems. I also added /usr/local/cuda/bin to my path and set LD_LIBRARY_PATH to /usr/local/cuda/lib64, per the instructions.

Next I ran to install the SDK, and finally I ran make from ~/NVIDIA_GPU_Computing_SDK/C.

That’s when I got the following error:

/usr/bin/ld: cannot find -lcuda

collect2: ld returned 1 exit status

Can anyone tell me what -lcuda is, and where it should be?

[NOTE: I’ve seen references in this forum to -lcudart, as well as to -lcuda, and I see that in my /usr/local/cuda/lib64/ directory I have libcudart.*, but no lcudart and no libcuda. Is this all okay?]


libcuda comes with the driver package, not the toolkit or SDK. If you are getting a libcuda not found error, it means either your driver installation didn’t work, or something is pretty broken in your compiler set up, because libcuda should always be in /usr/lib and never require any special environment settings for the linker to find it.