error: cannot find -lcuda

I have installed cuda on Fedora 8

Because I have no NV video card ,so I have not installed the driver

After I have installed the Toolkit and SDK successfully, I type “make emu=1 dbg=1”

But the result is :/usr/bin/ld:cannot find -lcuda, Why?
(I find there is no libcuda.so in the /usr/local/cuda/lib,
just becase I have not installed the driver?)

please help me , thanks in advance!

Did you run ‘make’ in main SDK directory? In your case, that would be ‘make emu=1 dbg=1’.

yes ,I have gone to the main SDK directory, and then type “make emu=1 dbg=1”. then the error is coming

I’m having then same problem.

I dont have a NV video card too and i cant to make the projetcs… :(

1.go to main SDK directory( not one of the project directory )

2.type “make emu=1” firstly

have a try~

Some of the SDK examples are written with the driver API and have no emulation mode. These are likely the ones causing the problem. Try building just the projects you want to try in emulation mode and they should work.

Hi Lucas,

I solved my problem…

  1. Get the NVIDIA Driver for Linux with CUDA Support from NVIDIAs CUDA Zone.
  2. Extract the .run, on terminal: $ sh ./NVIDIA-Linux-x86-177.73-pkg1.run --extract-only ./
    The name of the file can change.
  3. Copy the .so files of the driver packages to the other CUDA libraries (/usr/local/cuda/lib).
    Like: $ sudo cp ./NVIDIA-Linux-x86-177.73-pkg1/lib/
    .* /usr/local/cuda/lib/
  4. Add a symbolic link:
    cd /usr/local/cuda/lib/ ’sudo ln -s libcuda.so.177.73 libcuda.so’
    (In my case the lib is named “libcuda.so.177.73″. It my be different on your system.)
  5. Go to the SDK directory and run make with emulation option enabled:
    ‘make emu=1′ or ‘make emu=1 dbg=1′ for debug mode

I compiled every ok. But, when I try to run anything, I get it:
error while loading shared libraries: libcudart.so.2: cannot open shared object file: No such file or directory

:(