Cuda Emulation Mode

Hi. I’m trying to set up the nvidia SDK on a linux cluster where none of the computers have CUDA-capable graphics cards. This is to have an environment to debug codes that will run on other machines we have which do have the cards. I downloaded the SDK and Toolkit, and installed them to ~/sdk, and ~/cuda. After setting my $LD_LIBRARY_PATH and $PATH appropriately, I ran nvcc on a test code, and it worked fine. When I try to run the executable, however, I get this error message:

./test: error while loading shared libraries: cannot open shared object file: No such file or directory

The path to this libary file is in my LD_LIBRARY_PATH, so I’m confused as to why it isn’t working. In case it is relevant, the machines on the cluster run OpenSUSE 10.2. I do not have superuser permissions on these machines, but would still like to use them for testing and debugging purposes. If anyone has relevant information, please let me know. Thanks.

I get this error to, you have to setup the paths again. If there is a permenant way to link them I haven’t found it yet. But the great thing is it should still be cached somewhere. So just hit the up arrow in terminal and you can link it again.

I was getting the exact same error on my Linux 10.04 machine.
I had set the LD_LIBRARY_PATH correctly but it wasnt working.
So I added the required path to /etc/ and ran ldconfig as root.
It worked!!

Hope this helps :)