Installing Cuda without NVIDIA gpu Problem with libraries on system with an ATI video card.

I have arch linux 64-bit and I tried to install the cuda-toolkit on it. With some trouble I managed to do it, but withouth the dependency of the nvidia drivers, which of course I cannot install (I have an ATI card and only run programs in emulation mode). The compiler complains about “cannot find -lcutil” and I think they are part of the nvidia drivers. Could somebody help me to find those libraries? I think they can be extracted somehow from the driver package.

The library in question is not part of the driver - it is part of CUDA/GPU SDK. I don’t know what kind of program you are trying to compile, but you may try with installing SDK, and running make in the top-level directory - this particular library (as well as related libshrutil library) will be compiled first, and then the example programs will be compiled too. But if you are working on your own code, than you don’t have to use these libraries at all - libraries from the toolkit installation would be all that you’ll need.

The problem is when I try to install cuda-sdk, the compiler complains that “-lcuda” is missing, so where can I get that lib? I thought it came with the nvidia driver.

I think there should be a possibility to specify that you are compiling SDK for the emulation mode only. For example, with the SDK 3.0-beta, in the top-level Makefile, variable named “emu” is looked-up, and if this one set to 1, then not all examples are compiled - namely, examples that use driver API are skipped, and from further examination (of common/ makefile), seems to me that these examples are the only ones that are linking with libcuda, so I guess you may experiencing problems exactly on them. So, how about trying to run make, in the SDK top-level directory, through “emu=1 make”?


make emu=1

I’ve tried your suggestion and now finally cuda-sdk is installed. I can compile a program by manually typing “nvcc” (however, the program does not work correctly), but the makefile still does not work (emu is set to 1) I still get the following error:

[codebox]g++ -fPIC -o simpleproblem simpleproblem.cu_o -L/opt64/cuda/lib -L/opt64/cuda/NVIDIA_CUDA_SDK/lib -L/opt64/cuda/NVIDIA_CUDA_SDK/common/lib -lcudart -lGL -lGLU -lglut -L/opt64/cuda/lib -L/opt64/cuda/NVIDIA_CUDA_SDK/lib -L/opt64/cuda/NVIDIA_CUDA_SDK/common/lib -lcutil

/usr/bin/ld: cannot find -lcutil

collect2: ld returned 1 exit status

make: *** [simpleproblem] Error 1


maybe the compilation script from arch AUR for cuda-sdk is wrong or something like that…

If you want the nvidia libraries, get the driver package and run with -x (extract) to unpack the files.

For the SDK, cutil is in:
$ locate libcutil