compile with emulation mode

I’m trying to compile sdk, however I an error:

/usr/bin/ld: cannot find -lcutil

I’m using ubutu 7.04 with vmware.

That computer doesn’t have cuda capable gpu. Is there a way to compile it in emulation mode?


I tried to compile sdk with make emu=1 dbg=1

pmnox@pmnox-desktop:~/NVIDIA_CUDA_SDK$ make emu=1 dbg=1

make[1]: Entering directory `/home/pmnox/NVIDIA_CUDA_SDK/common’

a - obj/debug/bank_checker.cpp_o

a - obj/debug/cmd_arg_reader.cpp_o

a - obj/debug/cutil.cpp_o

a - obj/debug/stopwatch.cpp_o

a - obj/debug/stopwatch_linux.cpp_o

a - obj/debug/multithreading.cpp_o

make[1]: Leaving directory `/home/pmnox/NVIDIA_CUDA_SDK/common’

make[1]: Entering directory `/home/pmnox/NVIDIA_CUDA_SDK/common’

a - obj/debug/paramgl.cpp_o

a - obj/debug/param.cpp_o

make[1]: Leaving directory `/home/pmnox/NVIDIA_CUDA_SDK/common’

make -C projects/clock/

make[1]: Entering directory `/home/pmnox/NVIDIA_CUDA_SDK/projects/clock’

make[1]: Leaving directory `/home/pmnox/NVIDIA_CUDA_SDK/projects/clock’

make -C projects/matrixMulDrv/

make[1]: Entering directory `/home/pmnox/NVIDIA_CUDA_SDK/projects/matrixMulDrv’

/usr/bin/ld: cannot find -lcuda

collect2: ld returned 1 exit status

make[1]: *** […/…/bin/linux/emudebug/matrixMulDrv] Error 1

make[1]: Leaving directory `/home/pmnox/NVIDIA_CUDA_SDK/projects/matrixMulDrv’

make: *** [projects/matrixMulDrv/Makefile.ph_build] Error 2

You can skip compiling the *Drv packages by renaming each Makefile to Makefile-old. There is no way to run a Driver API program in emulation mode. The rest of the samples should work fine.

thx… Problem solved :]