SDK Manager

Dears,

I downloaded SDK manager on Ubuntu, when I click on install it does not work. I tried through the terminal, but have same problem.

E: Unsupported file ./sdkmanager-[1.1.0-6343].deb given on commandline
E: Unsupported file ./sdkmanager-[0.9.12-4180_amd64].deb given on commandline

what should I do? Thank you for assistance

These are to be added to the host PC, not the Jetson. For the host PC the file does not run directly, but instead can be added via something like this:

sudo dpkg -i /where/ever/it/is/sdkmanager-...version...-amd64.deb

(adjust for your file name)

Dear,

thank you, but does not work.

dpkg: error: cannot access archive ‘/where/ever/it/is/sdkmanager_0.9.12-4180_amd64.deb’: No such file or directory

I tried what mentioned here, but does not work

cd ~/where/ever/it/is

bash: cd: /home/cvision/where/ever/it/is: No such file or directory

The above is intended for you to edit and change “~/where/ever/it/is” with where the file really is. I don’t know where your file is stored, but somewhere you will be able to find “sdkmanager_0.9.12-4180_amd64.deb”. I have no idea where you saved it. If you use “cd” on command line you can go to that location, or name that location as a full path with “sdkmanager_0.9.12-4180_amd64.deb” appended to the path.

If you type “pwd” you will know where you are currently at. The directory “~” (tilde) is a shortcut to your home directory. The directory “.” is a shortcut to where you are at this moment. The directory “..” is a shortcut to the parent directory of the current directory. If you “cd” with no arguments you go to your home directory.

To illustrate, if you type “cd”, then then “pwd”, you will see your home directory. If you “pwd” then “cd .”, then “pwd” again, you’ll find you did nothing. If you type “pwd”, and there are a set of directories, then “cd ..”, then you will find you trimmed the deepest subdirectory out and are one step closer to “/” (which is the “root” of everything). Often your home directory can be seen with “echo $HOME”, and so “cd $HOME” would go to the same place as “cd ~”.

A typical download will go to “~/Downloads” or maybe it is at “~/Desktop”. Where is the file sdkmanager_0.9.12-4180_amd64.deb saved at?

If you type “ls”, then you will see the content of where you are. If you type “ls /home”, then you will see what is in “/home”. Perhaps you would want to run “ls ~/Downloads” or “ls ~/Desktop”. Sometimes it is “ls ~/nvidia” which is of interest.

Oh, okay. I got it. It’s on Download

will be as below with adding the version?

sudo dpkg -i /download/sdkmanager-...version...-amd64.deb

I was opened the terminal from Download but, did not work. will try once again.

Hi atefshkokani2009,

Please run below command on your host Ubuntu machine:

sudo apt install ./sdkmanager-…version…-amd64.deb

Does not work

cvision@cvision:~/Downloads$ sudo apt install ./sdkmanager_1.1.0-6343_amd64.deb
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘sdkmanager:amd64’ instead of ‘./sdkmanager_1.1.0-6343_amd64.deb’
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
sdkmanager:amd64 : Depends: libgconf-2-4:amd64 but it is not installable
Depends: libcanberra-gtk-module:amd64 but it is not installable
Depends: locales:amd64 but it is not installable
E: Unable to correct problems, you have held broken packages.

Hi atefshkokani2009,

Please run “sudo apt-get update” to fix your host machine problems.
Then install sdk*.deb again. Thanks!

Err:14 https://repo.download.nvidia.com/jetson/common r32.4 Release
Certificate verification failed: The certificate is NOT trusted. The certificate chain uses not yet valid certificate. Could not handshake: Error in the certificate verification. [IP:

Err:16 https://repo.download.nvidia.com/jetson/t210 r32.4 Release
Certificate verification failed: The certificate is NOT trusted. The certificate chain uses not yet valid certificate. Could not handshake: Error in the certificate verification. [IP: 92.122.215.65 443]
Err:17 http://ports.ubuntu.com/ubuntu-ports bionic InRelease
Cannot initiate the connection to ports.ubuntu.com:80

N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Hi atefshkokani2009,

Are you run the command on your host Ubuntu machine or Jetson device?
Please run the command on your host Ubuntu machine. Thanks!

it’s Ubuntu on Jetson.

What’s wrong with that?

Hi atefshkokani2009,

Please run the command on your host machine, not Jetson platform.

sudo apt-get update
sudo apt install sdkmanager_1.1.0-6343_amd64.deb

@atefshkokani2009
also you may try to run on x86_64 Ubuntu n from the folder where the .deb file is located the command below:

sudo dpkg -i sdkmanager_1.1.0-6343_amd64.deb 
./sdkmanager

do you have video illustrate that?

cvision@cvision:~/Downloads$ sudo dpkg -i ./sdkmanager_1.1.0-6343_amd64.deb
dpkg: error processing archive ./sdkmanager_1.1.0-6343_amd64.deb (–install):
package architecture (amd64) does not match system (arm64)
Errors were encountered while processing:
./sdkmanager_1.1.0-6343_amd64.deb

@atefshkokani2009
The only way you will be able to install sdkmanager is to execute the command from x_86_64 computer; Not from Jetson. Do you have x86_64 computer with Ubuntu OS?

No, but I have Virtual Machine on Windows includes Ubuntu. How can i do it and what should I move it to Jetson nano?