SDKManager "OS image ready" but nothing gets installed

Dear @SivaRamaKrishnaNV,
I could not execute stty -F /dev/ttyUSB1 115200, I had to use sudo
I could not execute the following echo commands, I had to use sudo su
(sudo alone did not work)

After successfully executing these commands I have tried to flash, and it worked.
Thank you for finding a workaround.

So, I will try to upgrade the p2379 as well. Which commands do I have to execute for flashing p2379?
Thank you.

Dear @hermann.fuerntratt,
You can use same commands for Autochauffer if the error is same. it sets the board in recovery mode.

So does the
echo tegrarecovery on > /dev/ttyUSB1
set both Tegras, A and B into recovery mode?

I am asking to be sure, as I can’t afford to make the p2379 unusable

Dear @hermann.fuerntratt,
Yes. Just flash normally with sdkmanager. If you notice the above issue with autochauffer also, Please check using commands and try flashing.

Dear @hermann.fuerntratt,
Any update on the issue?

Dear @SivaRamaKrishnaNV,
flashing with NVSDKManager only worked
after executing the following code lines before flashing:

sudu stty -F /dev/ttyUSB1 115200
sudo su
echo tegrarecovery b on > /dev/ttyUSB1
echo tegrarecovery a on > /dev/ttyUSB1
   
echo tegrareset b > /dev/ttyUSB1
echo tegrareset a > /dev/ttyUSB1

It would be nice, if that could be done from within the SDKManager though…

But - yes, I have upgraded to 1.2.400 now and are currently testing camera recording with 8 cams…
Thank you yery much for your help.

Dear @hermann.fuerntratt,
Thank you for the update. SDKManager scripts performs above commands but are seems to be failing on your machine. Hence requested you to run manually.

Dear @hermann.fuerntratt,
FYI, we have fixed the issue in next sdkmanager release

-sigh-
Hello @SivaRamaKrishnaNV,
not sure if I should open a new issue, but after updating Tegra A and B, I need to update Aurix as well.

Because I have tried to start the sample_camera_gmsl which failed with the following error:

root@tegra-ubuntu:/usr/local/driveworks/bin# ./sample_camera_gmsl
[3-12-2020 11:33:2] Initialize DriveWorks SDK v1.2.400
[3-12-2020 11:33:2] Release build with GNU 4.9.4 from v1.2.0-rc11-0-ga7f5475 against Vibrante PDK v5.0.10.3
[3-12-2020 11:33:2] Platform: Detected Drive PX2 - Tegra A
[3-12-2020 11:33:2] TimeSource: monotonic epoch time offset is 1606994455732280
[3-12-2020 11:33:2] TimeSource: PTP ioctl returned error. Synchronized time will not be available.
[3-12-2020 11:33:2] TimeSource: Could not detect valid PTP time source at ‘eth0’. Fallback to CLOCK_MONOTONIC.
[3-12-2020 11:33:2] Platform: number of GPU devices detected 2
[3-12-2020 11:33:2] Platform: currently selected GPU device discrete ID 0
[3-12-2020 11:33:2] SDK: Resources mounted from …/./data/resources
[3-12-2020 11:33:2] SDK: Create NvMediaDevice
[3-12-2020 11:33:2] SDK: Create NvMediaIPPManager
[3-12-2020 11:33:2] SDK: use EGL display as provided
[3-12-2020 11:33:2] SensorFactory::createSensor() -> camera.gmsl, output-format=yuv,fifo-size=3,camera-type=ar0231-rccb-bae-sf3324,csi-port=a,slave=0
[3-12-2020 11:33:2] CameraGMSL: required FPS = 30, resolution = 1920x1208
receive_from: Timeout Error.
Please check Ethernet ip configuration or
Update Aurix firmware version by the following command

sudo /bin/bash /etc/systemd/scripts/nv_aurix_check_fw.sh -auto_update

nvmedia isc: TacpCamPowerControl: 237: TACP command failed with ret -5
iscRootDevOpen: Failed to power on camera(s)
NvMediaISCRootDeviceCreate: Unable to open root device
nvmedia: ERROR: Init: Failed to create NvMedia ISC root device
[3-12-2020 11:33:7] Driveworks exception thrown: DW_SAL_CANNOT_CREATE_SENSOR: CameraGMSL: cannot connect to camera

terminate called after throwing an instance of ‘std::runtime_error’
what(): [2020-12-03 11:33:07] DW Error DW_SAL_CANNOT_CREATE_SENSOR executing DW function:
dwSAL_createSensor(&m_camera, params, m_sal)
at /builds/driveav/dw/sdk/samples/sensors/camera_gmsl/main.cpp:153
Aborted (core dumped)
root@tegra-ubuntu:/usr/local/driveworks/bin#/bin/bash /etc/systemd/scripts/nv_aurix_check_fw.sh -auto_update
starting Aurix FW checking…
Checking arguments…
Rootfs FW version is 4.02.04.0
No_Response_From_Aurix
Ping to 10.42.0.146
Try with virtual ethernet iface
Remove ethernet cable from port if board is connected to external network
Press any key to continue


!!! IMPORTANT INFORMATION BELOW REGARDING Aurix FW (PLEASE READ) !!!

Aurix is booted with old FW which doesn’t support Aurix OTA
Please Flash new FW from Windows based Flasher as provided by PDK

THIS MESSAGE WILL CONTINUE TO BE SHOWN UNTIL ACTION MENTIONED IS TAKEN
With action taken, this script will be muted and not shown again

Restore_default_network
root@tegra-ubuntu:/usr/local/driveworks/bin#

So can you please give me some information how to flash Aurix from Windows?

Dear @hermann.fuerntratt,
We recommend creating a new topic for each new issue.
Please check https://docs.nvidia.com/drive/active/5.0.10.3L/nvvib_docs/index.html#page/NVIDIA%20DRIVE%20Linux%20SDK%20Development%20Guide%2FFlashing%2Fflash_aurix_dpx.html%23wwpID0E0LE0HA

Thank you for the info, hopefully after that, I can start doing, what I am supposed to do…

Dear @hermann.fuerntratt,
FYI, sdkmanager 1.4.0 is available now. You can use this to flash the target with out any WAR.

Dear @SivaRamaKrishnaNV,
good news, after updating the NVSDKManager to 1.4.0 and reflashing Tegra A and B, the sample_camera_gmsl example works now as expected.
Thank you for your support.
The thing that does not work now is the network connection from host to target.
I cannot ping 10.42.0.28 or 29 (nor 146) from host.
On my p2379 I am able to ping all of them.
So, what is necessary, to have a LAN connection from my host to p2379 in order to upload my cross-compiled apps?

… especially, as /usr/local/driveworks/samples/cmake/UploadVibrante.cmake expects the target to be 192.168.10.10?

Dear @hermann.fuerntratt,
Note that, 10.42.0.28/29 are static IPs assigned to target and target is not expected to access via these IPs. Please change the IP address parameter in cmake to IP of target. You can check IP address of target in ifconfig after connecting to LAN. Make sure both target and Host are in same network to make it reachable.

But with which IP is target then expected to be accessed?

Host is 10.0.0.1, target is configured by isc-dhcp, but ifconfig on target does not show any IPv4 address except eth0.200 = 10.42.0.28 , which cannot be pinged from host ??

Dear @SivaRamaKrishnaNV,
for me, I can see 2 different expected IP addresses for p2379:

  1. 10.42.0.28 - Tegra A, set via isc-dhcp
  2. 192.168.10.10, expected via samples make upload

and host is expected to be 10.0.0.1
It would be very helpful, if documentation would give an overview, how these settings are expected to work together.

Dear @hermann.fuerntratt,
Please create a new topic with the following information to avoid cluttering of multiple issues in a single thread which creates confusion. I am assuming that you have not made any networking changes on both host and target after flashing and are connected via LAN.

  • Picture of ethernet connection to target
  • logs of ifconfig outputs for Host, Tegra A, Tegra B.

Note that, eth0.200 is VLAN interface used in tegra-aurix communication.