Sensor DS18B20 with 1-wire communication - Serial Port Problems

I’m trying to use the DS18B20 temperature sensors. For that I’m following these posts: Configuring DS18B20 temperature sensor using python on Jetson Nano and multiple ds18b20 sensors connection in jetson gpio pins
They are instructions for the use of this sensor with the Jetson nano.
However, I continually have problems to connect over the serial port (/dev/ttyS0).
I have connected the sensor and I already added my user to the dialout group and changed permission of the serial port with “sudo chmod a+rw /dev/ttyS0” as I found others have done to solve these kind of issues.
I still can’t use the port.
When I try to debug I get the exeption from the digitemp package: Serial Exception(“Could not configure port (5, ‘input/output error)’”)

I am using the Jetson AGX Xavier with ubuntu for an university project. I’m everything but experienced with either.
Any help is appreciated even just the right keywords to search further could be helpful.

Can you try configure the pin by jetson-io to try.

Following your post I did that with the “sudo /opt/nvidia/jetson-io/” command.
Pins 8 and 10 (RX, TX of UART) are configured as UART and I tried to activate an deactivate the handshake pins CTS and RTS (11,36) and connected them or left them without connection.
I still get the same error.
Is there another way to configure them?