Series 550 freezes laptop

I tried using Mesa, as it now supports NVK and thus allows me to use the nvidia without the driver.

It worked good at first glance, but I can’t stay with it because I lose access to cuda, which is needed for Blender rendering…

So until they finally fix this, I will be forced to stay in version 535.

nvidia-open-555.58-2 + X11 + KDE, no freezes 3 days.

Got it yesterday on shutdown with the new 555 closed source driver.

Arch Linux with XFCE on Xorg.

kernel: BUG: unable to handle page fault for address: 000000000003f249
kernel: #PF: supervisor read access in kernel mode
kernel: #PF: error_code(0x0000) - not-present page
kernel: PGD 0 P4D 0 
kernel: Oops: 0000 [#2] PREEMPT SMP NOPTI
kernel: CPU: 1 PID: 4184 Comm: chromiu:disk$3 Tainted: P S   UD    OE      6.9.7-zen1-1.1-zen #1 ada401ad7257f75841c37008401a305b20155156
kernel: Hardware name: LENOVO 20FW003PGE/20FW003PGE, BIOS R07ET97W (2.37 ) 11/25/2022
kernel: RIP: 0010:refill_obj_stock+0x56/0x1c0
kernel: Code: 81 e4 00 02 00 00 48 8d a8 00 20 03 00 48 8b 45 10 48 39 f8 0f 84 94 00 00 00 48 89 ef e8 12 f0 ff ff 49 89 c6 e8 da 72 d0 ff <49> 8b 07 a8 03 0f 85 fb 00 00 00 65 >
kernel: RSP: 0018:ffffa2b74b3337e0 EFLAGS: 00010002
-- Boot 6b1a6a9c7815461da6d831f863d11604 --
3 Likes

That the Nvidia open driver works is nice for all the users with “modern” GPUs in their laptops. However it doesn’t help users like me with older laptops that have GPUs not supported by the open driver. For example my six year old Lenovo Thinkpad T480s has a GeForce MX150 and is affected by this problem with all symptoms. While the MX150 isn’t the newest and fastest GPUs out there, but it still has his value for me when playing older games and some not-so-demanding CUDA applications.

For now I’m and likely other user with old GPU can stay on 535. But when 535 reaches EOL without the bug having been fixed in newer version I and all other users with old GPUs will have a problem.

3 Likes

Hey Guys.

Same Problem here with Arch Linux on Nvidia-dkms (555.58.02).

I’m using a Microsoft Surface Book 2 15" (i7-8650U, GTX1060 Mobile) running on Arch Linux (6.9.7-arch1-1-surface), KDE Plasma 6.1.2 ( Wayland).

The Desktop Environment runs on Intel iGPU (HD620).

However, I noticed when the Nvidia GPU is crashed (overheated or something else), the system will freeze.

Trying that now, how does it go 1 week later?

1 Like

There is rare KDE freezes when I work on my Vulkan/OpenGL app, so I have to switch to console and back to ui (ctrl+alt+f1 → ctrl+alt+f2) to make Plasma resume, but it was the same for 535.
Stable as 535.

1 Like

Mine freezes after a few days, when copying files from an SD card, on nvidia-open 555.58-2, linux 6.9.7.arch1-1.

With nvidia proprietary linux driver 555, nvidia.NVreg_EnableGpuFirmware=0 kernel option, Wayland and KDE Plasma 6.1 I have low CPU usage (around 5-20% for one core activity for kwin_wayland) and hight frame rate (around 70-75 fps with monitor refresh rate 75 Hz) on external monitor connected to nvidia HDMI port but I have kernels panics

With nvidia open linux driver 555, Wayland and KDE Plasma 6.1 I have hight CPU usage (around 20-80% for one core with activity for kwin_wayland) and low frame rate (around 65-70 fps with monitor refresh rate 75 Hz) on external monitor connected to nvidia HDMI port but I have not kernels panics

With nvidia proprietary linux driver 555, nvidia.NVreg_EnableGpuFirmware=1 kernel option, Wayland and KDE Plasma 6.1 I have hight CPU usage (around 20-80% for one core with activity for kwin_wayland) and low frame rate (around 65-70 fps with monitor refresh rate 75 Hz) on external monitor connected to nvidia HDMI port and I have kernels panics

So on nvidia proprietary driver (full closed mode) I have best performance, but I also have kernel panics
On nvidia open driver I have low performance, but have not kernel panics
On nvidia proprietary driver with Gpu Firmware enabled (default for 555) I have low performance and I have kernels panics.

Nvidia can not fix kernel panics with hybrid graphics five months

1 Like

Similar situation for me on arch latest (KDE)

proprietary 555 NVreg_EnableGpuFirmware=0 buttery smooth, low cpu usage. Initially frequent kernel panics. Since latest arch update couple of days ago haven’t panicked yet.

proprietary 555 NVreg_EnableGpuFirmware=1 dog sh*t frame rate, high cpu usage. Hasn’t panicked for about 5 days.

Currently using NVreg_EnableGpuFirmware=0 for couple days now. Haven’t panicked yet. But I suspect it will. Definitely something improved on plasma side I think in last couple of days.

Try using nvidia-open, no problems during at all during a week.

1 Like

Does the open Nvidia drivers have lower performance than the proprietary? Has anyone tested this on a laptop (I’ve got a 3070, anyone here with similar that tested it?)

Wayland? I am on X11

I’m on X11 as well.

1 Like

God damn it. Yet again completely unbootable system. After months kernel paniced during again reloading system phase. Looks like sudo touch /etc/systemd/do-not-udevadm-trigger-on-update no longer does the trick.

Just wasted 2 hours fixing my system. Nvidia god damn it FIX THIS ALREADY please

2 Likes

Proprietary driver is really bad

1 Like

So this problem is already 4 months old and it still has not been fixed. Literally 2 hours ago another kernel panic during an update broke my system for the 4th time already, it’s time to think about buying AMD

2 Likes

yep, same here but changing my actual laptop is too expensive for me RN. But my next upgrade for sure will not have an nvidia GPU.

2 Likes

560 driver is going to fix this because it forces the open kernel modules ;)

2 Likes

Not for pre-turing cards. And in the list of graphics supported by the driver there are pre-turing cards so this error should be solved.

The last communication was on April 29 and here we are still waiting…

1 Like