Set nvstreammux property num-surfaces-per-frame appropriately

Hi, I have set up a simple face detection pipeline. I have used “” this Image.

I am getting this error : - INFO: …/nvdsinfer/nvdsinfer_func_utils.cpp:39 [TRT]: Detected 1 inputs and 6 output network tensors.
0:00:32.426542760 697 0x5601ad93cc70 INFO nvinfer gstnvinfer.cpp:619:gst_nvinfer_logger: NvDsInferContext[UID 1]: Info from NvDsInferContextImpl::buildModel() <nvdsinfer_context_impl.cpp:1749> [UID = 1]: serialize cuda engine to file: /home/deepstream-test2/model_1.onnx_b2_gpu0_fp32.engine successfully
INFO: …/nvdsinfer/nvdsinfer_model_builder.cpp:685 [FullDims Engine Info]: layers num: 3
0 INPUT kFLOAT input_1:0 3x240x320 min: 1x3x240x320 opt: 2x3x240x320 Max: 2x3x240x320
1 OUTPUT kFLOAT softmax 4420x2 min: 0 opt: 0 Max: 0
2 OUTPUT kFLOAT concatenate 4420x4 min: 0 opt: 0 Max: 0

0:00:32.437920363 697 0x5601ad93cc70 INFO nvinfer gstnvinfer_impl.cpp:313:notifyLoadModelStatus: [UID 1]: Load new model:dstest2_pgie_config.txt sucessfully
set state to playingRunning…
Recording started…
ERROR from element stream-muxer: Input buffer number of surfaces (1836020585) must be equal to mux->num_surfaces_per_frame (4)
** Set nvstreammux property num-surfaces-per-frame appropriately**

Error details: gstnvstreammux.c(364): gst_nvstreammux_chain (): /GstPipeline:dstest2-pipeline/GstNvStreamMux:stream-muxer
**** ERROR: RunUserCallback:199: No video stream found**
Returned, stopping playback
Deleting pipeline
Time 32462588

I have tried with all the possible values that “num-surfaces-per-frame” property of “nvstreammux” can take, Still I’m getting the same error.

Can you lead me to probable causes of this error ??

Can you show you pipeline or the code you run?

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Hardware :- gpu Gforce 940M
DS version :-5.1
TRT version :- 7
nvidia-driver version :- 465
cuda - 11.1

Can you give the steps and necessary configs of reproducing the failure?

pipeline : source[filecource, location= argv[1]] > h264parser > decoder (nvv4l2decoder) > streammux > rest of the peipeline
#0=RGB, 1=BGR

0=FP32, 1=INT8, 2=FP16 mode


Can you post your code? Or you can try your nvinfer config file with deepstream-app sample to check whether the model is OK or not.

Model is okay. It was running on Jetson Nano.
Im trying to run it on docker instance.

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

Are you running with deepstream sample apps or you run with your own code?

Please tell us the detail steps of reproducing the failure. If you run with your own code, it’s better to provide your source code too.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.