Share feature generates whitelist errors and slows performance

I’m developing an application using Qt Quick (based on OpenGL) and I’m capturing video feeds from a capture card and/or a webcam. I’ve noticed a lot of errors in my Qt Creator console that look like:

IGIESW [path to .exe] found in whitelist: NO
IGIWHW Game [path to .exe] found in whitelist: NO

These repeat each time I try to activate a preview window or switch the source feed I’m trying to preview. It actually takes a few seconds and it really kills the responsiveness of my application. I have two nearly identical machines and I only see the errors on the machine with the NVIDIA graphics card; it doesn’t happen on the machine with Intel HD graphics. This lead me to believe it was an NVIDIA setting and on a hunch I tried disabling the “Share” feature in GeForce Experience and that fixed the problem!

I searched online for information about IGIWHW and IGIESW but I really couldn’t find much other than a few “my game won’t work” type forum posts.

I don’t see any reference to a whitelist in the Share settings nor in the online help for the NVIDIA control panel. I tried adding my path to the list of paths in the Games scanning settings but it didn’t help. Does anyone know where this whitelist is setup? It’s strange that even though the errors indicate that my app isn’t whitelisted it still works (just very slowly). It would be nice if it could just do this check and fail once at during startup rather than each time I press a button in my app to switch feeds.

I have GeForce driver version 378.78 and Experience version 3.4.0.70 running on Windows 10.

This msg’s: [IGIESW, IGIWHW Game found in whitelist: NO] in

[b]C:\Windows\SysWOW64\nvspcap.dll
C:\Windows\System32\nvspcap64.dll

Modules used by ShadowPlay capture.
[/b]

[b]
How off this msg’s and app init webcam more fast!
Solutions:

  • Open Geforce Experience -> General -> IN-GAME OVERLAY (Off)
    C:\Program Files (x86)\NVIDIA Corporation\NVIDIA GeForce Experience\NVIDIA GeForce Experience.exe

  • Use progress bar in your app “wait for init camera…”

Now I try understand how add app to whitelist.
I continue research…[/b]


NVIDIA Driver v385.41, Geforce Experience v3.9.0.61, Win10x64

I’m not sure I understand your response; from what I can tell if I turn off the overlay I can no longer record the screen. Since my original post I think the setting has been renamed from “Share” to “In-Game Overlay” but I believe it’s still doing the same thing.

I finded constant names in

C:\Windows\SysWOW64\nvspcap.dll
C:\Windows\System32\nvspcap64.dll

added to whitelist:

SkypeApp.exe, lync.exe, Skype.exe,
NvContainer.exe, NVIDIA GeForce Experience.exe, NVIDIA Share.exe,
OVRServer_x64.exe, dxdiag.exe, photoshop.exe,
msosync.exe, csisyncclient.exe, thunderbird.exe,
maya.exe, mayabatch.exe, devenv.exe, XboxApp.exe,
SearchUI.exe, consent.exe, video.ui.exe, microsoftedgecp.exe,
microsoftedge.exe, LogonUI.exe, firefox.exe,
chrome.exe, iexplore.exe, explorer.exe, nvCaptureCoreTest.exe,
nvstwiz.exe, nvspcaps64.exe, nvspcaps.exe

[b]That mean you can rename your app.exe to name like in list and check with In-Game Overlay (On).

I think in future NVIDIA Developers add functional for modify this whitelist manualy or patch dll if you can’t wait :)

I continue research…[/b]


NVIDIA Driver v385.41, Geforce Experience v3.9.0.61, Win10x64



I renamed my executable to Skype.exe and it worked! Thanks so much for looking into this. I really hope NVIDIA can address this someday and allow us to either whitelist our own apps or turn off the whitelist completely. If all you have to do is name the executable to get around the whitelist I don’t see how it could provide much security.