Significant delay in loading Xserver with proprietary driver on Kernel version above 5.15.0-48

I have an ubuntu 22.04 system with NVIDIA GeForce GTX 1050 Ti, proprietary drivers used to work perfectly fine on earlier Kernels but from 5.15.0-50 onwards it appears to have a significant delay in loading the system. Open source driver (xserver-xorg-video-nouveau) doesn’t seem to be having this issue and works fine with the latest Kernels.

With proprietary drivers, I’m getting “No video input” and “Entering standby mode” messages from the monitor while waiting to load Xserver. So far I have tried to use previous versions of NVIDIA drivers (470/510/515) but all of that seems to be having the same delay with new kernels.

I’m attaching the required files with this, please let me know if I could help bring any more info.
I’m having an ultrawide monitor - 49" Philips PHL 498P9 if it makes any difference.
nvidia-bug-report.log.gz (439.8 KB)


New users are only able to add one link on a message so - attaching other files one by one
systemd-analyze.txt (6.5 KB)

New users are only able to add one link on a message so - attaching other files one by one
critical-chain.txt (1.9 KB)

Exactly same issue!

A lot of discussion, useful logs with nvidia crash, videa and screenshots you can find ob Ubuntu bug tracker:

Please, help to us! A lot of users affected!

Also topic on Reddit:

Also my nvidia-bug-report.log.gz
nvidia-bug-report.log.gz (444.1 KB)

I have filed a bug 3851722 internally to track issue “Cannot login after new kernel installed”.
I tried locally to reproduce issue on below setup by couple of reboots followed by multiple suspend/resume operation but no luck so far.

Dell Precision T7610 + Genuine Intel(R) CPU @ 2.30GHz + Ubuntu 20.04.5 LTS + kernel 5.15.0-50-generic + NVIDIA GeForce RTX 2060 + Driver 515.65.01 + Display BenQ EL2870U

I will try to reproduce issue on few more test systems and update further on it.

Not sure if it’s going to make any difference, but can you try it on Ubuntu 22.04.1 LTS instead of 20.04.5 LTS? Thanks

For me problem starts after upgrading to kernel version 5.15.0-50. On kernel version 5.15.0-48 and above all was fine, no issue.

I have MLLSE RTX 3060.

Also i tried fresh install of Ubuntu 22,10 (Ubuntu with Unity) and have same issue.

My config:
i5-12400, GiGabyte H610M S2H DDR4, 2x16GB RAM (3200 mhz), MLLSE RTX 3060. Samsung monitor with HDMI output, 10080p,

XDG_SESSION_TYPE=x11 (no Wayland, X11). Security boot disabled.

journalctl -b command output with nvidia crash logs:
nv.log.gz (72.6 KB)

I have found the solution:

Shortly: try to disable internal videocard (Intel) on bios at all. For me helped.

Nice one @family-gan My issue is also sorted after disabling onboard intel GPU from BIOS

Please try once with driver 520.56.06 and share test results.

I tried 520.56.06 before, issue reproduce:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

I am able to reproduce issue where I cannot boot system with kernel version 5.15.0-50-generic and driver 515.76.
We are investigating the issue and update on it further.