[Solved] deviceQuery no response

I installed the CUDA Toolkit 7.0 on a Ubuntu 12.04.5 LTS machine through the net install (downloaded the little deb package and then installed with sudo apt-get install cuda). I did everything that was written on Linux Getting Started Guide (http://developer.download.nvidia.com/compute/cuda/7_0/Prod/doc/CUDA_Getting_Started_Linux.pdf). The device is a QUADRO K600.

The display driver that was installed along with everything else was nvidia-346. I compiled the examples and then executed deviceQuery

$ ./deviceQuery
    ./deviceQuery Starting...

     CUDA Device Query (Runtime API) version (CUDART static linking)

I read here to reboot the computer - didn’t help. I also tried to restart the driver with nvidia-smi -r where there is also no response and no return.

deviceQueryDrv also gives no response.

I’ve installed CUDA Toolkit 7 in a Ubuntu 14.04 machine with a GT520M with no problems.

Any idea how to solve this?

try installing with the runfile installer

Thanks for the input. I had tried to do that before with an older version (5.5) and it didn’t go so well for me. I think that time I was having troubles with drivers’ conflicts.

I ended up removing everything CUDA and NVidia related and installed the 6.5. .deb. I haven’t tested exhaustively but it seems to be working now.