(Solved) xrandr 1.5 with setprovideroutputsource failed with nvidia driver 418.56-2 on debian+Quadro P400

Hello,
I’m trying to use multiple graphics cards on my debian testing (buster) but I can’t, because xrandr 1.5 with setprovideroutputsource failed with nvidia driver 418.56-2. I use non-free “nvidia-driver” debian meta-package.

xrandr display “BadValue (integer parameter out of range for operation)”

# lspci |grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GP107GL [Quadro P400] (rev a1)
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV505 [Radeon X1550 64-bit]

$xrandr  --listproviders
Providers: number : 2
Provider 0: id: 0x251 cap: 0x1, Source Output crtcs: 4 outputs: 6 associated providers: 0 name:NVIDIA-0
Provider 1: id: 0x44 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 2 outputs: 3 associated providers: 0 name:ATI Radeon X1550 64-bit @ pci:0000:02:00.0

$xrandr  --setprovideroutputsource "NVIDIA-0"
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  35 (RRSetProviderOutputSource)
  Value in failed request:  0x251
  Serial number of failed request:  16
  Current serial number in output stream:  17

xrandr work well to change screen resolution anyway but I need to use “setprovideroutputsource” option to set multiple screen with.
I have same issue with only one graphic cards.

Could you help me, plz?

Thxs
Pascal B

Syntax error?
Please try

xrandr --setprovideroutputsource 1 0

Thxs for your help.

Right with “xrandr --setprovideroutputsource 1 0” or with “ati radeon” previous “nvidia”

xrandr --setprovideroutputsource "ATI Radeon X1550 64-bit @ pci:0000:02:00.0" "NVIDIA-0"

I haven’t error message and then xrandr display my second screen on DVI-1-0:

$ xrandr
Screen 0: minimum 8 x 8, current 1280 x 1024, maximum 32767 x 32767
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 connected primary 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024     60.02*+  75.02  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   640x480       75.00    72.81    59.94  
DP-5 disconnected (normal left inverted right x axis y axis)
VGA-1-0 disconnected (normal left inverted right x axis y axis)
S-video-1-0 disconnected (normal left inverted right x axis y axis)
DVI-1-0 connected (normal left inverted right x axis y axis)
   1280x1024     60.02 +  75.02  
   1280x960      60.00  
   1152x864      75.00  
   1280x720      60.00  
   1024x768      75.03    70.07    66.01    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    59.94  
   720x400       70.08  
  1280x1024 (0x45) 108.000MHz +HSync +VSync

but as soon I want to enable my second screen with

xrandr --output DP-4 --mode 1280x1024 --primary --preferred --current --output DVI-1-0 --mode 1024x768 --right-of DP-4

kde (or X) crash, I’m on KDM, need to login again and xrandr command didn’t list my second screen DVI-1-0 anymore.

You should rather run
xrandr --auto
as second command and then use the kde monitor manager for placement.

ty I already try.
xrandr --auto crash kde too
after “xrandr --setprovideroutputsource 1 0” I’m going in kde monitor manager and I can see my second screen DVI-1-0 but disabled. I enable it and apply … without effect: DVI-1-0are still disabled

Does it work if you use the modesetting driver instead of radeon?
Please run nvidia-bug-report.sh as root after a crash and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Here nvidia-bug-report.sh result
nvidia-bug-report.log.gz (1.02 MB)

Looks like a bug in the radeon DDX:

[  1116.498] randr: failed to create shared pixmap
[  1116.498] (EE) 
[  1116.498] (EE) Backtrace:
[  1116.499] (EE) 0: /usr/lib/xorg/Xorg (OsLookupColor+0x139) [0x55f9011fbfc9]
[  1116.500] (EE) 1: /lib/x86_64-linux-gnu/libpthread.so.0 (funlockfile+0x50) [0x7f6295cb377f]
[  1116.500] (EE) 2: /usr/lib/xorg/modules/libfb.so (_fbGetWindowPixmap+0x9) [0x7f62941b3ed9]
[  1116.501] (EE) unw_get_proc_name failed: no unwind info found [-10]
[  1116.501] (EE) 3: /usr/lib/xorg/modules/drivers/radeon_drv.so (?+0x0) [0x7f629449f410]
[  1116.501] (EE) 4: /usr/lib/xorg/Xorg (xf86CrtcSetModeTransform+0x286) [0x55f901110896]
[  1116.502] (EE) 5: /usr/lib/xorg/Xorg (xf86PruneDuplicateModes+0x25b7) [0x55f901119e37]
[  1116.502] (EE) 6: /usr/lib/xorg/Xorg (RRCrtcSet+0x2d3) [0x55f901158433]
[  1116.503] (EE) 7: /usr/lib/xorg/Xorg (ProcRRSetCrtcConfig+0x29f) [0x55f901159b7f]
[  1116.503] (EE) 8: /lib/x86_64-linux-gnu/libXext.so.6 (nvidiaAddDrawableHandler+0x50c1ed) [0x7f6294f89e8a]
[  1116.503] (EE) 
[  1116.503] (EE) Segmentation fault at address 0x10

Please try with the modesetting driver. In order to do so, change the file
/usr/share/X11/xorg.conf.d/10-radeon.conf
From

Section "OutputClass"
	Identifier "Radeon"
	MatchDriver "radeon"
	Driver "radeon"
EndSection

to

Section "OutputClass"
	Identifier "Radeon"
	MatchDriver "radeon"
	Driver "modesetting"
        Option "AccelMethod" "none" 
EndSection

then run
xrandr --setprovideroutputsource modesetting NVIDIA-0 && xrandr --auto

It doesn’t work:

$ xrandr --setprovideroutputsource modesetting NVIDIA-0
$ xrandr --auto
xrandr: Configure crtc 4 failed
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  21 (RRSetCrtcConfig)
  Value in failed request:  0x0
  Serial number of failed request:  61
  Current serial number in output stream:  61

Maybe I must try with debian stable?

nvidia-bug-report.log.gz (1.03 MB)

The distro doesn’t matter, the radeon stuff just is a bit rusty.
Try this for /usr/share/X11/xorg.conf.d/10-radeon.conf

Section "OutputClass"
   Identifier "Radeon"
   MatchDriver "radeon"
   Driver "radeon"
   Option "AccelMethod" "glamor"
   Option "ColorTiling" "false"
EndSection

Then use
xrandr --setprovideroutputsource 1 0 && xrandr --auto

Ok thxs my second monitor connected at radeon card work better with

xrandr --setprovideroutputsource 1 0
xrandr --output DP-4 --mode 1280x1024 --primary --preferred --output DVI-1-0 --mode 1024x768 --right-of DP-4

(–auto doesn’t work)

but unfortunaly my cursor could not jump at second monitor because when my cursor move to monitor side, all kde desktop slide on main screen (nvidia connected).
How can I disable this slide?

KDE’s monitor manager is interfering. Try to run the second command twice or disable KDE’s kscreen2 service.

\o/ thxs a lot for your time to help me.

To understand,
Option “AccelMethod” “glamor”
Option “ColorTiling” “false”

I found on page https://www.x.org/releases/current/doc/man/man4/radeon.4.xhtml

Option "ColorTiling" "boolean"
The framebuffer can be addressed either in linear or tiled mode. Tiled mode can provide significant performance benefits with 3D applications. Tiling will be disabled if the drm module is too old or if the current display configuration does not support it. On R600+ this enables 1D tiling mode.
The default value is on for R/RV3XX, R/RV4XX, R/RV5XX, RS6XX, RS740, R/RV6XX, R/RV7XX, RS780, RS880, EVERGREEN, and CAYMAN and off for R/RV/RS1XX, R/RV/RS2XX, and RS3XX.

(I have [AMD/ATI] RV505)

and on https://www.freedesktop.org/wiki/Software/Glamor/ (Glamor has been merged into Xorg server 1.16)
It’s a GL-based rendering acceleration library for X server

Yes, but basically those options are just needed to work around bugs in the radeon driver regarding PRIME, can be found in the xorg bugzilla so there’s no deeper meaning to them.