sound coming out of GPU very noisy

Here is the problem started about the time I upgraded Nvidia driver to 418. I watch youtube videos; started out no problem, after screen is locked and logged back in, the sound becomes very noisy.

Nvidia driver 418.87.07
Card : GTX 980 Ti
Ubuntu 18.04

Monitors :
ASUS 21’ and ASUS 24’

Display driver :
Ancor Communications Inc ASUS MG24U (DP-4)
Ancor Communications Inc ASUS VH222H(DP-3)

Any suggestion ?
nvidia-bug-report.log.gz (843 KB)

Do you mean the sound from the video played over your monitor?
Please run as root after the issue appears and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.

I generated the report (nvidia-bug-report.log.gz), see attached.

It’s happening right now as I’m playing a youtube video at the same time I’m typing this reply…

Which monitor are you using for sound output? Does this happen with both?

It happens with both.

Even stranger is when I select Speakers-Built-in-Audio (see attached screen shot), sound improves and the noise disappears. But that’s not always the case.

Forgot to mention this. For a long time until recently, when I log in, there’s this low frequency humming noise constantly on.

The only way to get ride of it is by Settings -> Sound -> Output, click Test Speakers, then hit Test on Front Right, Front Left.

But recently this login noise is gone. The new problem is sound quality of video has deteriorated, become noisy, making it very annoying to watch youtube.

I found a solution, though why it works remains a mystery. Here is what I did.

First, I kill pcmC1D3p,

lsof | grep pcm
kill -9 [the process id]

Then I restart pulseaudio,

systemctl --user restart pulseaudio

After this, audio coming out of youtube is crytal clear. It works every single time.

The side effect is, under Settings --> Sound, under Output (Choose a device for sound output), everything is gone, blank. And I wouldn’t be able to change volume with the volume keys. However, that’s OK as I could adjust volume using the volume icon in browser. This’ totally a hack, but I couldn’t find any other fix.