Static IP for wlan0 wifi for ssh

Hi all,
I don’t know if here its the right place for this topic. But I will try.
I have a jetson nano devkit with TP-LINK Archer T2U wifi adapter on it , and I would like to set a static IP for the wlan0 connection , so that way it will startup with the same wlan0 IP and I can ssh it with the same IP every time.

I tried this example (on the response) with switching “eth0” to “wlan0” and ofcourse with my network details:

And it didn’t work - the jetson couldn’t find any network even though the wifi was enabled.

I will be greatful for a begginer level explanations and help for how to make it.
Thanks in advance!!

Setting static IP on WiFi via the Jetson is the wrong way to do this. You need to go into the router’s admin access and assign a specific IP address to the MAC address of the Jetson’s WiFi (pick a specific IP for the WiFi, and another one for wired). For MAC addresses on the Jetson see:

Thank you very much for the quick response.
will try that one.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.