Stuck in Max Performance mode after hibernation (Perf. State: P0 / Level 4) - 410.73 - RTX 2070 - Ke...

Using kernel 4.18.0 on Debian/sid with an RTX 2070 card running 410.73 drivers (nvidia installer used for the latter) and X.Org X Server 1.20.3. When the GPU is idle it will enter Performance State : P8 (as seen in nvidia-smi) or Performance Level: 0 (in nvidia-settings -> PowerMizer).

However after # systemctl hibernate and booting again, the level is stuck on maximum, i.e. P0/4. Then (according to nvidia-smi) the idle power draw goes up from ~21W to ~48W - and most annoyingly the temperature hits ~55° C where the fans start spinning, stop, spin again, etc. (though that might be a vendor problem).

Apart from rebooting simply restarting X also helps - but that defeats the point of hibernating in the first place. I tried changing the virtual terminal before hibernating (chvt 1; sleep 5; systemctl hibernate), installed acpid (something about it missing was the only relevant message in the Xorg.log) - all unsuccessfully. I also read through the 415.13 beta changelog, but saw nothing relevant so I have not tried these.

The xorg.conf was generated by nvidia-xconfig, the kernel dmesg contains the following entry 3x upon booting, but nothing else.
resource sanity check: requesting [mem 0x000c0000-0x000fffff], which spans more than PCI Bus 0000:00 [mem 0x000c0000-0x000dffff window]
[ 8977.978444] caller _nv001126rm+0xe3/0x1d0 [nvidia] mapping multiple BARs

This is fixed in 418.43 (using kernel 4.19.0-4). Currently in the lowest power state P8 after two suspend-resume cycles.

I did not test 415.27, it might be fixed there as well according to amrits: https://devtalk.nvidia.com/default/topic/1046058/linux/-gtx-1070-driver-4-15-25-performance-mode-p0-does-not-automatically-downshift-to-idle-p8-after-/post/5309576/#5309576