High idle power draw RTX 2070 Super

Hey, when idle the power draw is about 55w which seems very high. I’m using a dual 1080p 144hz monitor setup, with one of the monitors reporting as 143.61hz which also has g-sync. The “PowerMizer” in nvidia-settings seems to be stuck at level 4 which is probably what is causing this.

However, when I set both monitors to 60hz the power draw gets reduced to 37w and the “PowerMizer” goes back down to level 0, but 37w still seems high when idling.

The high power draw is causing the fans to constantly spin up to high speeds and then shut off again, which is annoying the hell out of me.

nvidia-smi with both monitors at 144hz

+-----------------------------------------------------------------------------+
| NVIDIA-SMI 470.57.02    Driver Version: 470.57.02    CUDA Version: 11.4     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA GeForce ...  Off  | 00000000:08:00.0  On |                  N/A |
|  0%   57C    P0    55W / 215W |    311MiB /  7979MiB |      0%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|    0   N/A  N/A       962      G   /usr/lib/Xorg                     133MiB |
|    0   N/A  N/A      1009      G   /usr/bin/gnome-shell              175MiB |
+-----------------------------------------------------------------------------+

nvidia-smi with both monitors at 60hz

+-----------------------------------------------------------------------------+
| NVIDIA-SMI 470.57.02    Driver Version: 470.57.02    CUDA Version: 11.4     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA GeForce ...  Off  | 00000000:08:00.0  On |                  N/A |
|  0%   54C    P8    37W / 215W |    353MiB /  7979MiB |      9%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|    0   N/A  N/A       962      G   /usr/lib/Xorg                     146MiB |
|    0   N/A  N/A      1009      G   /usr/bin/gnome-shell              203MiB |
|    0   N/A  N/A     30877      G   nvidia-settings                     0MiB |
+-----------------------------------------------------------------------------+

Is this a bug? am I doing something wrong?

nvidia-bug-report.log.gz (380.0 KB)

1 Like

This looks like a bug.

I can confirm this as well.

I also have the 2070 Super.

If I set any of my monitors (I have 2) to 144hz the power level will not drop below 4. If I disable the secondary monitor the power level will drop normally with the primary on 144hz but will remain on level 4 if that second monitor is connected even at 60hz.

If I turn my monitors to both 60hz refresh then my power level also drops normally.

In effect I can completely verify the OP’s issue with the added test of turning off one monitor.

This seems to be a regression as I remember a similar issue a while back (maybe drivers 395?) where if you had both monitors set at 144hz the power level would stay at 4 but if you turned the secondary to 60hz the power levels would drop as normal under light loads.

I am using a more recent driver that the OP so the issue has not been resolved with the newer driver.

I am using Arch and an using the drivers from the Arch repos. Linux kernel 5.13.13-arch1-1

this is nvidia-smi under no load, just the desktop and a few app running but nothing that would not normally have the power level dropping down to 1

+-----------------------------------------------------------------------------+
| NVIDIA-SMI 470.63.01    Driver Version: 470.63.01    CUDA Version: 11.4     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA GeForce ...  Off  | 00000000:08:00.0  On |                  N/A |
|  0%   52C    P0    34W / 215W |    739MiB /  7979MiB |      0%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+

The power level should be at one and the temp should then drop to about 30-40C. With the power level stuck at 4 the temp stays at around 50C under the same conditions. The fans do work as they should when the temp rises a bit but the card should not be maintaining this temp unless I have a game or other graphically demanding program running

Are the devs currently working on a fix so that the next update may include a fix for this issue and if so do we have an eta and driver version of the potential fix?

I’ve read some more threads about this issue and it doesn’t seem exclusive to Arch or the 2070 Super like this one: PowerMizer Performance always at max, cannot control GPU fan manually
He says that

Others have mentioned this is intentional; probably because there are too many pixels to shove through the pipeline

But that makes no sense because this wasn’t an issue with his 3080 card, and it’s no issue on Windows either.

I just wish if it were intentional Nvidia would at least comment on one of these threads and tell us, or if it’s a bug that they acknowledge it exists and are working on it.

Oh the bump of the last comment reminded me to post an update.

The 470.74 driver update DID NOT fix the issue, still the same symptoms

I hope they are working on this and will have a fix out soon

Upload nvidia-bug-report and hope this thread gets noticed.

Communicating with NVIDIA in regard to bugs has always been fucked up. They have a special linux email address as well, but I’ve sent a number of emails to it and haven’t received a single confirmation or reply.

I am able to duplicate issue after connecting display LG Electronics UL TRAGEAR with refresh rate 179.96 Hz on below configuration setup –

Alienware Area-51 R6 + AMD Ryzen Threadripper 1950X 16-Core Processor + Ubuntu 20.04.3 LTS + 5.4.0-81-generic + Driver 470.63.01 + NVIDIA GeForce RTX 2080 + BenQ EL2870U with 60 Hz + LG Electronics UL TRAGEAR with refresh rate 179.96 Hz

I have filed a bug 3423370 internally for tracking purpose.

3 Likes

Same problem here.
My GTX 1080 sits almost all the time at P0 consuming 48-50W when doing nothing.
It sometimes drops to lower power modes but it lasts only a few seconds before ramping up to P0 again.

Would love to have a fix to save some energy and have my card working in passive mode (fan 0%).

Specs:
OS: Ubuntu 21.10 x86_64
Kernel: 5.13.0-21-generic
Resolution: 1080x1920 (60Hz), 2560x1440 (144Hz GSYNC)
DE: GNOME
CPU: Intel i7-5820K (12) @ 4.400GHz
GPU: NVIDIA GeForce GTX 1080
GPU Driver: 470.82.00

1 Like

Driver 470.86 doesn´t fix the problem.

1 Like

Any news on this?

1 Like

I’m quite curious about this also. The latest drivers still don’t have this issue fixed. It’s very jarring :(

1 Like