PowerMizer Performance always at max, cannot control GPU fan manually

There are two things I noticed about my Eurocom Sky X7C laptop (Clevo P775TM1-G clone): First, I cannot reduce the Performance level, it constantly sits at 4. Second, the GPU fan is constantly on despite not being used.

The GPU is rarely used; it sits around 3-7% range while I use my laptop for work. The laptop has two monitors attached to it via Display Port. So in total, I have 3 screens; my laptop and two DELL monitors.

If I disconnect one of the monitors (doesn’t matter which one), the Performance Levels are adaptive to the GPU load and I can watch the level jump around between 0 and 4 as necessary. However, if I plug both monitors in, the performance level stays at 4. No amount of tweaking helps. If I unplug the laptop, the performance level adjusts, but doesn’t drop below 2.

The GPU fan in my laptop is constantly on. It’s being controlled by the V-BIOS, but I’d like to manually configure the fan curve. Unfortunately, all my approaches have so far failed. No tools, not even nvidia-smi can read the fan RPM.

Computer stays idle overnight and when I log on in the morning, the GPU temperature is around 55C. The fan is basically off at this point. So the variance in temperature is around 55-62C during the day. The laptop sits on a stand and has no other heat sources.

So what can be done here? Is there some way to control the GPU fan? Is there some way to drop the performance level with this many screens?

EDIT: Unplugging one of the monitors and/or closing the lid on my laptop allows the performance level to go into Adaptive mode. The result is a 5C drop in temperature and it allows the GPU fan to drop to almost inaudible levels. This is a temporary solution.

EDIT2: Seems many people are running into maxed out performance levels. Others have mentioned this is intentional; probably because there are too many pixels to shove through the pipeline.

Nvidia Bug Report Logs: Upload files for free - nvidia-bug-report.log.gz - ufile.io

I didn’t have this issue on an RTX 3080 but I do have it on an RTX 3080 Ti. The 3080 could clock down to the lowest power level even with 4 monitors connected and I didn’t have any performance issues. Now with the 3080 Ti I am stuck at the highest power level if more than 2 monitors are connected and powered on. It does clock down when the monitors go into standby. On this card the wattage difference is 28w vs 93w. Since it worked fine on the 3080, I don’t think it’s because there’s not enough power available at the lowest power level. My GPU usage is 0-2% sitting idle on the desktop with 4 monitors, so there’s no reason it couldn’t drop down to a lower power level. I consider this a bug, but there is no response from Nvidia.

The 3080 that it worked on was a Zotac Amp Holo. The 3080 Ti that it doesn’t work on is an EVGA FTW3 Ultra Hybrid. Not sure if the brand and their firmware settings have anything to do with it, or if it’s the driver’s fault.