Cannot change performance level

I’ve got a RTX 2070 Super Max-Q in my working laptop using Ubuntu 22.04. The internal graphics card is disabled, so pure nvidia.
Preferred mode is adaptive, of course.

For whatever reason, the performance level is stuck at 3 (300-2100 Mhz GPU, 11002-11002 Mhz memory). Graphics clock is around 1215 Mhz while doing absolutely nothing (utilization is below 1%). This means, the fan will often be on.

How do I make it reasonable? Reasonable means:

  • Why is the performance level not 0 or at least 1? Why am I not allowed to change it? How do I change it and make it stay at this setting forever?
  • Why is the graphics clock not at 300 Mhz when idle? It’s the most obvious thing everyone wants - when its doing nothing, it should not produce heat / noise. Especially in a laptop. How do I change it so it works like it should?

Ubuntu 22.04
NVIDIA Driver Version 510.73.05
X.Org Version: 1.21.1.3
NV-CONTROL Version: 1.29
2 external screens (DP + HDMI), AC plugged in.

Known issue, if there are multiple monitors connected, the nvidia driver sets the gpu to highest performance level (more bits have to be pushed).
Check the forum for (bad) workarounds.