How to keep GPU at Performance Level 1?

  • Nvidia Driver version 510.54 (X .org)
  • Pop!_OS 21.10
  • Linux Kernel 5.16.15-76051615-generic
  • DE: GNOME 40.5

Hi. I have a Galax GT 1030 ExOC White (30NPH4HVQ5EW) . It has a Base Clock of 1253 MHz , and Boost Clock of 1502 MHz , and a Memory Clock of 1502 MHz . That’s fine .

But because of Nvidia’s Adaptative/Dynamic Boost, GPU Clock can reach 1936 MHz and Memory Clock at 6008 MHz . This happens both on Windows and Linux . This is good, but in some games and applications it can make my GT 1030 unstable and crash the entire PC.

-Here’s a screenshot of my Nvidia X Server settings: Captura de tela de 2022-04-11 12-02-29.png - Google Drive

I want to know if it is possible to set the Nvidia Driver to stay at Performance Level 1 and never jump to Level 2. Or ideally, set a custom GPU and Memory Clock and stay that way 6008 MHz for VRAM is too much for my GT 1030, way above what it was made for. But Nvidia X Server Settings doesn’t have any option to set Clock Speeds. So, is this possible?

I checked ~/nvidia-settings-rc config file but there’s no variable there to set a prefered Performance Level.