Limit GTX 1050Ti clock frequence

Hi,

I’m experiencing some thermal shutdown issues with GTX 1050 Ti with Dell XPS 15 9570.
I installed CUDA 9.0 with driver 390.77.

I would like to limit the GPU clock but by running the following command

nvidia-smi -q -d SUPPORTED_CLOCKS

The output is

==============NVSMI LOG==============

Timestamp : Fri Mar 8 13:00:07 2019
Driver Version : 390.77

Attached GPUs : 1
GPU 00000000:01:00.0
Supported Clocks : N/A

Thus, I’d like to ask if it is possible to limit the clock of the GPU?
Thank you very much in advance.

Though I would rather clean/repair the cooling system, you can try any of those:
https://devtalk.nvidia.com/default/topic/1039521/linux/dramatic-overall-performance-and-heat-generation-with-geforce-gtx-1070-with-max-q-design/post/5284598/#5284598
Use another value than 0x1. This will probably limit the clocks more than you want in any case, though.
The supported/application clocks setting is mostly only available on quadro/teslas and refers to compute applications.

Hi generix,

Thank you for your reply, actually Dell just replaced my motherboard so the system is brand new.
I tried to add

options nvidia NVreg_RegistryDwords="OverrideMaxPerf=0x1"

to /etc/modprobe.d/nvidia.conf

But this file didn’t exist, I created it and added the line. After restarting the system, NVIDIA X Server setting showed that the GPU is still at level 3 performance.

Did I do something wrong?

Thx!

Hi, again,

After executing

sudo update-initramfs -u

The config file works!
Thank you so much!