Can not to lock GPU clock - RTX 4090

Hi guys!

Can not to lock GPU clock.

Motherboard: TUF GAMING B450M-PLUS II
OS: Kali Linux 2024.1
GPU: GeForce RTX™ 4090 GAMING OC 24G (rev. 1.0)
NVIDIA Driver Version: 525.147.05
CUDA Version: 12.0

sudo nvidia-smi -pl 600

Power limit for GPU 00000000:06:00.0 was set to 600.00 W from 450.00 W.

sudo nvidia-smi -pm 1

Enabled persistence mode for GPU 00000000:06:00.0.

sudo nvidia-smi -i 00000000:06:00.0 --lock-gpu-clocks=2900

GPU clocks set to “(gpuClkMin 2900, gpuClkMax 2900)” for GPU 00000000:06:00.0

After starting the hashcat gpu frequency not rise higher than 2750.

nvidia-smi -q (under load)