Quadro P6000 clock lock

Hi, I recently received a Quadro P6000 GPU from the Nvidia University program. I am trying to use it on a PC with Ubuntu 18.04 and the nvidia-390 drivers but it seems to be very slow.

When forcing the maximum performance setting from the driver control panel, the graphics clock frequency is capped at around 300 MHz. When I try to run some CUDA code, it even drops below that to 100 MHz. Trying to force a higher freuency with nvidia-smi -ac does not have any effect. Power supply should not be an issue and temperatures are fine.

I’m not sure what’s the cause of this issue. Could it be that the clock is actually hardware-limited? Mind that this is not a commercial card, but one given away for free by the grant program for universities so it might be some card downtuned for stability reasons.

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post will reveal a paperclip icon.
Things to try:

  1. Upgrade to driver 396, use the graphics ppa for that:
  2. Add a file /etc/modprobe.d/99-nvidia-modeset.conf containing
options nvidia-drm modeset=1

After that, run

sudo update-initramfs -u

and reboot.

sudo cat /sys/module/nvidia_drm/parameters/modeset

should return ‘Y’ if done right.

I tried all of that without success. Even with the 396 drivers and modeset=1, the problem is still the same. I am attaching the output of nvidia-bug-report.sh and a screenshot.

I should add that I tested on the same system a 1080 Ti that I bought and it’s working fine. The problem is only on the Quadro.
nvidia-bug-report.log.gz (122 KB)

Ok, the problem is:

HW Power Brake Slowdown : Active

So the slot seems to emit the PWRBRK signal.
See if a bios update for your board is available or if you can change the slot.