Stuck on boot screen with conflicting NVIDIA graphics packages

I was having issues with nvidia drivers essentially when i “locked” my desktop on gnome, gdm would crash. I wanted to fix it, i started by updating everything (ID 204), after my computer locked it self, gdm crashed and i did a hard shutdown, after booting up i realized i was using noveau, i tried updating (ID 206, ID 207) and it said nvidia had some broken dependencies so i tried to remove the nvidia drivers and the latest kernel (and reinstall both). After doing that the latest kernel was still available but it wouldnt show a gui so i booted up an older kernel (with the nvidia kmod already built) to fully remove nvidia drivers and to reinstall them. sad to say my computer didnt boot up again.
Relevant dnf history

This is what i see the entire time (i cant switch to any TTY)

This is the last picture i have of my working system:

Here’s the repos i had

Here’s the nvidia packages currently installed

Here’s some errors i found in my bootlogs relevant to this issue:

  1. systemd-udevd[2347]: /usr/lib/udev/rules.d/60-nvidia.rules:2 Invalid value "/usr/bin/bash -c '/usr/bin/mknod -Z -m 666 /dev/nvidiactl c $(grep nvidia-frontend /proc/devices | cut -d \ -f 1) 255'" for RUN (char 61: invalid substitution type), ignoring.

  2. /usr/lib/udev/rules.d/60-nvidia.rules:3 Invalid value "/usr/bin/bash -c 'for i in $(cat /proc/driver/nvidia/gpus/*/information | grep Minor | cut -d \ -f 4); do /usr/bin/mknod -Z -m 666 /dev/nvidia${i} c $(grep nvidia-frontend /proc/devices | cut -d \ -f 1) ${i}; done'" for RUN (char 28: invalid substitution type), ignoring.

  3. /usr/lib/udev/rules.d/60-nvidia.rules:4 Invalid value "/usr/bin/bash -c '/usr/bin/mknod -Z -m 666 /dev/nvidia-modeset c $(grep nvidia-frontend /proc/devices | cut -d \ -f 1) 254'" for RUN (char 66: invalid substitution type), ignoring.

  4. /usr/lib/udev/rules.d/60-nvidia.rules:5 Invalid value "/usr/bin/bash -c '/usr/bin/mknod -Z -m 666 /dev/nvidia-uvm c $(grep nvidia-uvm /proc/devices | cut -d \ -f 1) 0'" for RUN (char 62: invalid substitution type), ignoring.

  5. /usr/lib/udev/rules.d/60-nvidia.rules:6 Invalid value "/usr/bin/bash -c '/usr/bin/mknod -Z -m 666 /dev/nvidia-uvm-tools c $(grep nvidia-uvm /proc/devices | cut -d \ -f 1) 1'" for RUN (char 68: invalid substitution type), ignoring.

I think the problem has to do with the fact that i was, unknowingly, still using the f37 cuda repo (yes i installed cuda when i was using f37). I tried following the steps listed here to no avail. What can i do to fix the issue?

It’s stuck in the EFI stub so the kernel doesn’t even boot. Already tried to disable secure boot?

Yes i already tried removing secure boot. The computer itself does boot, i can go to a live usb, chroot into the root partiton and use journalctl to list all boots on my system and it will show the boot.

In the end the solution was to remove everything nvidia by using

dnf remove *nvidia*

and to follow this comment for grub edits.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.