Installing issue NVIDIA-Linux-x86_64-260.19.26.run driver in Ubuntu 10.4 64bit CUDA 3.2 Toolkit

Hi all,
I am just following to CUDA 3.2 toolkit guide to install 260.19.26.run driver in Ubuntu 10.4. Iam still not success. Anyone got the same issue?
My card is NVS 3100M, supporting CUDA. When I install the driver using Hardware driver search it take only 195…series driver, its not supporting for CUDA3.2.
according the guide, i did sudo /etc/init.d/gdm stop to stop GUI , then i could not continue to run # sh NVIDIA-Linux-x86_64-260.19.26.run

Please anyone can help to solve this…
Thanks in advance
Vishva

I did the following and it worked fine:

Ctrl+Alt+F1

[entered login, then password]

sudo service gdm stop

sudo sh NVIDIA-Linux-x86_64-260.19.26.run

sudo service gdm start

Although I’m kinda experiencing problems with gpumat but that’s another story.

For me, I am using Fermi C2050 with Ubuntu 64bit and I have to run under safe graphics mode. The error I get is (EE) No Devices Found. Is there a solution?

Thanks

Abhi

Hi

============================================
Ctrl+Alt+F1
[entered login, then password]
sudo service gdm stop
sudo sh NVIDIA-Linux-x86_64-260.19.26.run

sudo service gdm start

Finally I did same as you, But Nvidia installer identified the Nouveau kernel and did not pass, then I have added a disable-nouveau.conf file to add nouveau kernel in blacklist. Then my installation was successful.
But my headache now is, I dont get display now!!! i rebooted many times…
I try with recovery boot also… no display…

Pls help me to the display back!!! should i use CD to boot and recover???

Maybe some parameters should be added to grub??? I encountered similar problems.

Here is my grub.conf:title Fedora (2.6.34.7-61.fc13.x86_64)

    root (hd0,5)

    kernel /boot/vmlinuz-2.6.34.7-61.fc13.x86_64 ro root=UUID=302e3b99-abd6-4d15-80de-2bfc377b6025 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet nouveau.modeset=0 rdblacklist=nouveau vmalloc=256m

    initrd /boot/initramfs-2.6.34.7-61.fc13.x86_64.img

“nouveau.modeset=0 rdblacklist=nouveau vmalloc=256m” were added. Ubuntu has similar/same parameters.

Good luck.

disable nouveau?

If you read the Ubuntu wiki on NVIDIA binary drivers here, you see that you need to disable noveau first

Great article, very useful, thanks :)

Finally I have succeeded with my Nvidia 260.26.19 installation. Thanks guys your comments help me lot.
http://us.download.nvidia.com/XFree86/Linux-x86/256.35/README/commonproblems.html
This nvidia guide also helped me.
You have to disable Nauveau in boot and also in some systems you have to off X server too by editing xconf file in X11 folder.
Hopefully it will help someone.
Lets rock with CUDA!!!
thanks
vishva

The easiest way I found to install this new driver under Ubuntu 10.04 is the following:

  1. Extract the driver without installing first:
    Get the driver from nvidia.com
    ./dev…run --extract-only

  2. While running X, select System -> Administration->Hardware Drivers
    this will search for hardware requiring proprietary drivers
    select the one with [most recent]
    This will download and install the drivers

  3. If not installed yet, copy libcuda and libglx to their places.

  4. Reboot and you have the new driver installed and cuda enabled.