Install CUDA 3.0 under Ubuntu 10.04 ?

Hello,

I’d like to know how to install CUDA 3.0 drivers under linux Ubuntu 10.04

I’ve tried to remove the native nvidia drivers with : sudo apt-get remove nvidia*, then I blacklisted the nouveau, nv, rivafb… in modprobe.d\blacklist.conf file,
I’ve installed the GCC 4.3

i’ve stopped the gdm to launch : sudo sh devdriver*

but it still tells me there’s a conflit with nvidia.ko !

I’ve already succesfully installed them because I found the right tutorial after 2 days of searching, but now i’m stuck

can somebody please help me ?

I had one system (NF980-G65) which loaded nouveau even though it was blacklisted. I think because it was an embedded display. Use “lsmod” and see if nouveau is listed anyway, or one of the other drivers.

I solved it by holding shift while booting to bring up the GRUB menu, then picking the “recovery” mode and dropping straight to a shell without starting X even once. Once I got the nvidia driver installed, it used that from now on.

Finally, make sure that gcc is symlinked to gcc 4.4 (not 4.3). That’s what the driver needs to compile a kernel module. After the driver is running, I symlink gcc back to gcc-4.3 for CUDA compiles.

hmm Im having the same problem, and i managed to get done of the black listed stuff to load, successfully installed it… but after undoing theblacklist and rebooting, it fails to load the module and X gives me a nice error message telling me cant load the nvidia module…

any suggestions…

also my x session is not on ctrl+alt+F3 and when i kill gdm it doesnt even drop to a shell just a blinking underscore haha

ok so i think ive solved it.

first we need to remove all nvidia stuff, so do:

sudo apt-get --purge remove nvidia-*

then add the following lines to :/etc/modprobe.d/blacklist.conf

blacklist nouveau

blacklist vga16fb

blacklist rivafb

blacklist nvidiafb

blacklist rivatv

then reboot into recover mode

if it freaks out and asks what it wants you to do say drop to root shell or something

and then execute

telinit 3

then

sudo sh ./to/where/you/driveris.run

go through all the fancy prompts and reboot…

voila… its done(hopefully)

ref:http://forums.techarena.in/operating-systems/1336959.htm

ref:http://forums.nvidia.com/index.php?showtopic=167422

and a few others…

http://ubuntu-ky.ubuntuforums.org/showpost…amp;postcount=5

Under 10.10 I had the same problems, but I also had to add the following and had to update the ramfs

append to blacklist.conf

blacklist nouveau

options nouveau modeset=0

blacklist vga16fb

blacklist rivafb

blacklist nvidiafb

blacklist rivatv

and then run:

$> sudo update-initramfs -u

then reboot as mentioned above and install.

Under 10.10 I had the same problems, but I also had to add the following and had to update the ramfs

append to blacklist.conf

blacklist nouveau

options nouveau modeset=0

blacklist vga16fb

blacklist rivafb

blacklist nvidiafb

blacklist rivatv

and then run:

$> sudo update-initramfs -u

then reboot as mentioned above and install.

Did anyone faced any problems while installing cuda driver when there is already a built in graphics card? My laptop has integrated intels graphics card and nvidia’s graphics card. So when i try to install its not able to install the driver correctly. Infact after installing I cannot even run xserver.
Can somebody help me with this?

Did anyone faced any problems while installing cuda driver when there is already a built in graphics card? My laptop has integrated intels graphics card and nvidia’s graphics card. So when i try to install its not able to install the driver correctly. Infact after installing I cannot even run xserver.
Can somebody help me with this?

hi

i install cuda in ubuntu 10.04 by using this address
but i have yet problem installation

kazem@kazem-desktop:~/NVIDIA_GPU_Computing_SDK/C$ sudo makemake[1]: Entering directory /home/kazem/NVIDIA_GPU_Computing_SDK/C/common' make[1]: Leaving directory /home/kazem/NVIDIA_GPU_Computing_SDK/C/common’
make[1]: Entering directory /home/kazem/NVIDIA_GPU_Computing_SDK/C/common' make[1]: Leaving directory /home/kazem/NVIDIA_GPU_Computing_SDK/C/common’
make[1]: Entering directory /home/kazem/NVIDIA_GPU_Computing_SDK/C/common' make[1]: Leaving directory /home/kazem/NVIDIA_GPU_Computing_SDK/C/common’
make[1]: Entering directory /home/kazem/NVIDIA_GPU_Computing_SDK/shared' make[1]: Leaving directory /home/kazem/NVIDIA_GPU_Computing_SDK/shared’
make -C src/nbody/
make[1]: Entering directory /home/kazem/NVIDIA_GPU_Computing_SDK/C/src/nbody' /usr/bin/ld: cannot find -lGL collect2: ld returned 1 exit status make[1]: *** [../../bin/linux/release/nbody] Error 1 make[1]: Leaving directory /home/kazem/NVIDIA_GPU_Computing_SDK/C/src/nbody’
make: *** [src/nbody/Makefile.ph_build] Error 2

other question:after setup driver my resolution is very bad and system can not detect my graphic and i do not have x server in system.
what am i doing?

thanks

Sounds to me like your driver install was not successful.

did you install the newest driver?

thanks for answer

yes

i install 260.19.26 model that was last driver in nvidia!

did it give you any error installing the driver?

also if it askes during the install you should make sure to let it generate a new xorg.conf

do not any error installing