Stutter in application when running xrandr on Orin 32Gb Module

Hello there

I have a simple open gl application which draws a vertical line to the hdmi output, the line moves left to right at a fixed speed.

On Jetson Orin 32Gb module the line stutters (skips a few frames) whenever I run the xrandr command.

On Jetson Nano module the line continues to run smoothly whenever I run the xrandr command.

This is an issue for us because we have another commercial application which is experiencing the same stuttering issue when we check the display output status with xrandr.

What can we do to resolve this?

cat /etc/nv_tegra_release

R35 (release), REVISION: 1.0, GCID: 31250864, BOARD: t186ref, EABI: aarch64, DATE: Thu Aug 11 03:40:29 UTC 2022

Hi,
We would need your help to share a test sample so that we can reproduce it and check further. We have samples in

/usr/src/nvidia/graphics_demos/

Please check if you can share a patch on either sample. Or a standalone test sample.

The same problem can be seen when I run
cd /usr/src/nvidia/graphics_demos/bubble/x11
./bubble -windowsize 640 480

then from a second machine via ssh and/or by alt tabbing to a 2nd console window
then I just run
xrandr

the stutter is obvious

Hi,
We follow the steps but do not hit the issue. Please execute sudo nvpmodel -m 0 and sudo jetson_clocks. The steps enable system at maximum performance mode. Please try and see if the issue disappears.

OK Yes I tried your steps and the same problem still occurs

FYI I am using and Avermedia D315 carrier board and I am using the HDMI output. Do you think this is causing the problem some how?

Not really sure, do you have Orin devkit to try again?