"sudo apt-get update" fails on Jetson nano

I was trying to run the sudo apt-get update command on jetson nano r32.5.1 and I get the following error.

E: The repository ‘https://repo.download.nvidia.com/jetson/common r32.5 Release’ no longer has a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository ‘https://repo.download.nvidia.com/jetson/t210 r32.5 Release’ no longer has a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I tried the following solution, but the issue remains jetson repo error during apt-get update - #2 by carolyuu

How can I fix this issue ?

Hi malith,

Please check apt source configuration file:

$ sudo vi /etc/apt/sources.list.d/nvidia-l4t-apt-source.list
deb https://repo.download.nvidia.com/jetson/common r32.5 main
deb https://repo.download.nvidia.com/jetson/t210 r32.5 main

Run apt-get update again.

Hi, @carolyuu ,

Thank you for the reply.

I checked the apt source configuration file and it is same as the above. And apt-get update command fails.

Just to make sure, I tried to access the above urls from the browser. And both the links respond with “Not found”. Isn’t that the issue causing the above error ?

Hi malith,

We can’t hit your errors when run apt-get update.
Please try open below link:
https://repo.download.nvidia.com/jetson/

If you can open it, please try again “apt-get update”, if still got the same errors, please provide full apt update logs.
If you can’t open it, please check your network setting.

Hi @carolyuu ,

Yes. I can open the above link. But “apt-get update” still gives error.

Here is the full log

tqc_adm@titdtedge1:~$ sudo apt-get update
[sudo] password for tqc_adm:
Get:1 file:/var/cuda-repo-10-2-local-10.2.89 InRelease
Ign:1 file:/var/cuda-repo-10-2-local-10.2.89 InRelease
Get:2 file:/var/visionworks-repo InRelease
Ign:2 file:/var/visionworks-repo InRelease
Get:3 file:/var/visionworks-sfm-repo InRelease
Ign:3 file:/var/visionworks-sfm-repo InRelease
Get:4 file:/var/visionworks-tracking-repo InRelease
Ign:4 file:/var/visionworks-tracking-repo InRelease
Get:5 file:/var/cuda-repo-10-2-local-10.2.89 Release [574 B]
Get:5 file:/var/cuda-repo-10-2-local-10.2.89 Release [574 B]
Get:6 file:/var/visionworks-repo Release [2,001 B]
Get:6 file:/var/visionworks-repo Release [2,001 B]
Get:7 file:/var/visionworks-sfm-repo Release [2,005 B]
Get:7 file:/var/visionworks-sfm-repo Release [2,005 B]
Get:8 file:/var/visionworks-tracking-repo Release [2,010 B]
Get:8 file:/var/visionworks-tracking-repo Release [2,010 B]
Ign:9 https://repo.download.nvidia.com/jetson/common r32.5 InRelease
Ign:10 https://repo.download.nvidia.com/jetson/t210 r32.5 InRelease
Err:11 https://repo.download.nvidia.com/jetson/common r32.5 Release
Could not handshake: An unexpected TLS packet was received. [IP: 192.168.0.1 3128]
Err:13 https://repo.download.nvidia.com/jetson/t210 r32.5 Release
Could not handshake: An unexpected TLS packet was received. [IP: 192.168.0.1 3128]
Hit:16 Index of /ubuntu-ports bionic InRelease
Hit:18 Index of /ubuntu-ports bionic-updates InRelease
Hit:19 Index of /ubuntu-ports bionic-backports InRelease
Hit:20 Index of /ubuntu-ports bionic-security InRelease
Reading package lists… Done
E: The repository ‘https://repo.download.nvidia.com/jetson/common r32.5 Release’ no longer has a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository ‘https://repo.download.nvidia.com/jetson/t210 r32.5 Release’ no longer has a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Here is the content of "/etc/apt/apt.conf"

Acquire::http::proxy "http://192.168.0.1:3128/";
Acquire::https::proxy "https://192.168.0.1:3128/";
Acquire::ftp::proxy "http://192.168.0.1:3128/";

Hi malith,

After check logs, it should be your network proxy setting issue.
Please reference this page: virtualbox - apt update: Could not handshake: An unexpected TLS packet was received - Ask Ubuntu

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.