Swap memory is not being used by the code

NVIDIA product - Jetson Nano 2gb
operating system - Linux

Issue - I have my yolov4 tiny code for object tracking running on Jetson Nano 2gb, but the issue is of lower frame rate on Jetson Nano 2gb, I have already created extra swap memory of 5.9GB on Jetson. Still while running the codes it is not using the Swap memory created and thus it is giving me lower frame rate in outputs.

I would like to have a solution on how to increase the FPS while detection and how do I make the code utilize the swap memory which I have made.


Please noted that swap memory cannot be access by GPU.
It won’t increase the memory amount available for GPU.


Is it possible to run the codes only on CPU and not using the GPU ?
If yes then could you let me know how?

For my current code its shows memory out of space and it is not using the extra SWAP memory. I need at least 2.4GB of free memory to run the code, is there any way to do it?


Which YOLOv4 source do you use?
Could you share it with us so we can give it a check?



I am currently using this -
GitHub - theAIGuysCode/yolov4-deepsort: Object tracking implemented with YOLOv4, DeepSort, and TensorFlow. repo for my yolov4 code.

I am using the same code for trial on Jetson but swap memory is not being used.
Please check


The shared example uses TensorFlow for inference.
You can disable GPU in TensorFlow via following setting:

import os
os.environ['CUDA_VISIBLE_DEVICES'] = '1'