Syntax highlighting?

I’m using PGI visual fortran 2008 7.2.4
I’m a beginner at programing fortran using visual studio.

I just started a .f90 file to program something and I noticed that there is no “Syntax Highlighting”. Like the comments would be green color, or “program” would be in blue color, etc

Anyone know how to turn syntax highlighting on?

thanks

Hi Zii,

You can customize the font and background colors from the ‘Tools->Options’ Menu and then select the ‘Environment->Fonts and Colors’ option.

Have fun!
Mat

the font and colors didn’t do anything, but I did found out something.

If I just open the .f90 file without opening the project then there would be syntax highlighting, but if I open a project or create a project there wouldn’t have the highlighting. But it works fine for C++ and C#, so it’s got to be a PGI Fortran problem.

any ideas

Hi Zii,

I asked one of our PVF engineers and she would like you to please verify that when you open a new PVF Console Application that the default file is not colorized.

Thanks,
Mat

Hi Mat,
Though I’m currently using an evaluation license, I can confirm that the default setting in Visual Studio 2005 for a new project is for plain text instead of code (I’m using PGI version 8.0.4 both 32 and 64 bit). I cannot make PVF recognize my .f90 as source code with automatic syntax highlighting.
The programs do compile though…
Also, the PGI fortran extension does not show up as an option is visual studio as an editor extension either (tools-options-text_editor-file_extensions).

Nick

Hi Nick,

Unfortunately we have not been able to reproduce this behavior here with a standard PVF installation.

Are you using VS 2005 or VS 2008?
Do you have any other languages besides PVF installed (i.e., VC++, IVF, CVF, etc.)?
What Windows version do you have?

Any additional information that would help us recreate the issue would be much appreciated.

Thanks!
Mat

Hi Nick,

Another thing that might be helpful is if you can post the values of the following registry entries:

HKEY_CLASSES_ROOT.f90
HKEY_CLASSES_ROOT\PGI.f90.9.0
HKEY_LOCAL_MACHINE\Software\Microsoft\Wow6432Node\VisualStudio\9.0\Languages\File Extensions.f90

If you are using VS 2005, use “8.0” where “9.0” appears above.

  • Mat